summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoriFlygo2023-03-21 18:16:43 +0800
committeriFlygo2023-03-21 18:16:43 +0800
commitb95404f1e7bb584c9b44a0252fc171b3e5c3766c (patch)
treee44232d3643d207b7c482dca99f0d9a6dcfb262f
downloadaur-b95404f1e7bb584c9b44a0252fc171b3e5c3766c.tar.gz
initial
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD38
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0d4f860637f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = figma-linux-git
+ pkgdesc = Figma-linux is an unofficial Electron-based Figma desktop app for Linux.
+ pkgver = 0.10.0
+ pkgrel = 1
+ url = https://github.com/Figma-Linux/figma-linux
+ arch = x86_64
+ license = GPL
+ makedepends = rust
+ makedepends = npm
+ conflicts = figma-linux
+ source = figma-linux::git+https://github.com/Figma-Linux/figma-linux.git
+ sha256sums = SKIP
+
+pkgname = figma-linux-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..515f9f7106cd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+# ignore all
+*
+
+# pkg
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..235aef1154b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: iFlygo <iflygo@outlook.com>
+
+_pkgname=figma-linux
+pkgname=$_pkgname-git
+pkgver=0.10.0
+pkgrel=1
+pkgdesc="Figma-linux is an unofficial Electron-based Figma desktop app for Linux."
+arch=('x86_64')
+url="https://github.com/Figma-Linux/figma-linux"
+license=('GPL')
+conflicts=("$_pkgname")
+depends=(
+
+)
+options=(
+
+)
+makedepends=(
+ 'rust'
+ 'npm'
+)
+source=("${_pkgname}"::'git+https://github.com/Figma-Linux/figma-linux.git')
+sha256sums=("SKIP")
+
+prepare() {
+ cd "${_pkgname}"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ npm i
+ npm run build
+}
+
+package() {
+ echo "test"
+
+}