summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2020-08-03 20:15:34 -0400
committerSolomon Choina2020-08-03 20:15:34 -0400
commit32e2e2e422f3d5d4d8428aed453270b30d67f0d1 (patch)
tree049860bb7ef8be1695938a5267b4d01a00898277
parent79d53fe7d84a6d0df118a6c452331320c1f100b7 (diff)
downloadaur-32e2e2e422f3d5d4d8428aed453270b30d67f0d1.tar.gz
Removing dependencies that are not needed, Adding Submodules, and other fixes
thanks to the commentors of the project
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD55
2 files changed, 57 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c3ed72575e9..33e930cb2128 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,30 @@
pkgbase = file-commander-git
pkgdesc = Qt-based cross-platform Total Commander-like orthodox file manager for Windows, Mac and Linux
- pkgver = 0.9.4.8.r1.g9847b08
+ pkgver = 0.9.4.12.471.r0.g42c8aa5
pkgrel = 1
url = https://github.com/VioletGiraffe/file-commander
arch = i686
arch = x86_64
license = GPL3
makedepends = qt5-tools
+ makedepends = hunspell
depends = qt5-base
- depends = qt5-multimedia
- depends = hunspell
- source = file-commander-git::git+https://github.com/VioletGiraffe/file-commander
+ optdepends = hunspell
+ provides = file-commander
+ conflicts = file-commander
+ source = git+https://github.com/VioletGiraffe/file-commander.git
+ source = git+https://github.com/VioletGiraffe/cpp-template-utils.git
+ source = git+https://github.com/VioletGiraffe/cpputils.git
+ source = git+https://github.com/VioletGiraffe/github-releases-autoupdater.git
+ source = git+https://github.com/VioletGiraffe/image-processing.git
+ source = git+https://github.com/VioletGiraffe/qtutils.git
+ source = git+https://github.com/VioletGiraffe/text-encoding-detector.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = file-commander-git
diff --git a/PKGBUILD b/PKGBUILD
index 55d1fc7e0790..b799f38dcb60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,61 @@
pkgname=file-commander-git
_pkgname=file-commander
-pkgver=0.9.4.8.r1.g9847b08
+pkgver=0.9.4.12.471.r0.g42c8aa5
pkgrel=1
pkgdesc='Qt-based cross-platform Total Commander-like orthodox file manager for Windows, Mac and Linux'
arch=('i686' 'x86_64')
url="https://github.com/VioletGiraffe/file-commander"
license=('GPL3')
-options=()
-depends=('qt5-base' 'qt5-multimedia' 'hunspell')
-makedepends=('qt5-tools')
-source=("$pkgname::git+$url")
-sha256sums=('SKIP')
+depends=('qt5-base')
+makedepends=('qt5-tools' 'hunspell')
+optdepends=('hunspell')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/VioletGiraffe/file-commander.git'
+ 'git+https://github.com/VioletGiraffe/cpp-template-utils.git'
+ 'git+https://github.com/VioletGiraffe/cpputils.git'
+ 'git+https://github.com/VioletGiraffe/github-releases-autoupdater.git'
+ 'git+https://github.com/VioletGiraffe/image-processing.git'
+ 'git+https://github.com/VioletGiraffe/qtutils.git'
+ 'git+https://github.com/VioletGiraffe/text-encoding-detector.git')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
- cd "$pkgname"
+ cd "$srcdir/${pkgname%-git}"
git describe --long --tags | sed 's/v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare(){
- cd "$srcdir/$pkgname"
- git submodule update --init --recursive
+ cd "$srcdir/${pkgname%-git}"
+ git submodule init
+ for submodule in cpp-template-utils cpputils github-releases-autoupdater \
+ image-processing qtutils text-encoding-detector; do
+ git config submodule.${submodule}.url "$srcdir/${submodule}"
+ done
+ git submodule update
+
+ # Fix icon name
+ sed -i 's/Icon=icon/Icon=file-commander/g' qt-app/file_commander.desktop
}
build() {
- cd "$srcdir/$pkgname"
- qmake PREFIX=/opt/$_pkgname
+ cd "$srcdir/${pkgname%-git}"
+ qmake PREFIX=/usr
make
}
package() {
- cd "$srcdir/$pkgname"
- mkdir -p $pkgdir/opt/$_pkgname
- cp -r $srcdir/$pkgname/bin/release/x64/* $pkgdir/opt/$_pkgname
- mkdir -p $pkgdir/usr/bin/
- install -Dm755 $pkgdir/opt/$_pkgname/FileCommander $pkgdir/usr/bin
+ cd "$srcdir/${pkgname%-git}"
+ make INSTALL_ROOT="$pkgdir/" install
+
+ # Rename icon
+ mv "$pkgdir/usr/share/icons/hicolor/256x256/apps/icon.png" \
+ "$pkgdir/usr/share/icons/hicolor/256x256/apps/${pkgname%-git}.png"
}