summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2017-07-01 23:03:04 -0400
committerSolomon Choina2017-07-01 23:03:04 -0400
commite24516f52d8e8b6555bfe55d31f1387ced771226 (patch)
tree8931ee0378f055e4f3cd15c31bd1a3c2ba7dedd1
downloadaur-e24516f52d8e8b6555bfe55d31f1387ced771226.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1636edb4977b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Jul 2 03:02:52 UTC 2017
+pkgbase = file-commander-git
+ pkgdesc = A simple fullscreen word processorQt-based cross-platform Total Commander-like orthodox file manager for Windows, Mac and Linux
+ pkgver = 0.9.3.2.r33.g7efe4eb
+ pkgrel = 1
+ url = https://github.com/VioletGiraffe/file-commander
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = qt5-tools
+ depends = qt5-base
+ depends = qt5-multimedia
+ depends = hunspell
+ source = file-commander-git::git+https://github.com/VioletGiraffe/file-commander
+ sha256sums = SKIP
+
+pkgname = file-commander-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..885fc50a0561
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+pkgname=file-commander-git
+pkgver=0.9.3.2.r33.g7efe4eb
+pkgrel=1
+pkgdesc='A simple fullscreen word processorQt-based cross-platform Total Commander-like orthodox file manager for Windows, Mac and Linux'
+arch=('i686' 'x86_64')
+url="https://github.com/VioletGiraffe/file-commander"
+license=('GPL3')
+depends=('qt5-base' 'qt5-multimedia' 'hunspell')
+makedepends=('qt5-tools')
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare(){
+ cd "$srcdir/$pkgname"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ qmake PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ mkdir -p $pkgdir/opt/$pkgname
+ cp $srcdir/$pkgname/bin/release/* $pkgdir/opt/$pkgname
+ mkdir -p $pkgdir/usr/bin/
+ ln -s $pkgdir/opt/$pkgname/FileCommander $pkgdir/usr/bin
+
+}