summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2022-10-17 08:05:53 +0200
committerChristian Hesse2022-10-17 08:05:53 +0200
commitfa54c3a9167aa0237d897aca92aacba26b96eea6 (patch)
treec3ac5781e6ed67be5b48dce2024a603a0615d4fb
parent11d1feefb1fb5591619bf1e33d80c3618b8ade16 (diff)
downloadaur-file-git.tar.gz
commit file-git 5.43.r81.g4cfda317-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD38
2 files changed, 36 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3cc0754c2e4c..44b65434664e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,23 @@
pkgbase = file-git
pkgdesc = File type identification utility - git checkout
- pkgver = 5.21.r4.g4f2c3a6
+ pkgver = 5.43.r81.g4cfda317
pkgrel = 1
url = http://www.darwinsys.com/file/
arch = i686
arch = x86_64
- groups = base
groups = base-devel
license = custom
makedepends = git
+ depends = glibc
depends = zlib
+ depends = xz
+ depends = bzip2
+ depends = libseccomp
+ depends = libseccomp.so
+ provides = libmagic.so
provides = file
conflicts = file
- source = git://github.com/file/file
+ source = git+https://github.com/file/file.git
sha256sums = SKIP
pkgname = file-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 8221a8ed2c89..7a295ed55524 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,45 +4,63 @@
# Contributor: Andreas Radke <andyrtr@archlinux.org>
pkgname=file-git
-pkgver=5.21.r4.g4f2c3a6
+pkgver=5.43.r81.g4cfda317
pkgrel=1
pkgdesc='File type identification utility - git checkout'
arch=('i686' 'x86_64')
license=('custom')
-groups=('base' 'base-devel')
+groups=('base-devel')
url='http://www.darwinsys.com/file/'
-depends=('zlib')
+depends=('glibc' 'zlib' 'xz' 'bzip2' 'libseccomp' 'libseccomp.so')
makedepends=('git')
-provides=('file')
+provides=('libmagic.so' 'file')
conflicts=('file')
-source=('git://github.com/file/file')
+source=('git+https://github.com/file/file.git')
sha256sums=('SKIP')
pkgver() {
cd file/
if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
- echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ printf '%s.r%s.g%s' \
+ "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG})" \
+ "$(git rev-list --count ${GITTAG}..)" \
+ "$(git rev-parse --short HEAD)"
else
- echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ printf '0.r%s.g%s' \
+ "$(git rev-list --count master)" \
+ "$(git rev-parse --short HEAD)"
fi
}
+prepare() {
+ cd file/
+
+ autoreconf -fi
+}
build() {
cd file/
- autoreconf -fi
- ./configure --prefix=/usr --datadir=/usr/share/file
+ ./configure \
+ --prefix=/usr \
+ --datadir=/usr/share/file \
+ --enable-fsect-man5 \
+ --enable-libseccomp
make
}
+check() {
+ cd file/
+
+ make check
+}
+
package() {
cd file/
make DESTDIR="${pkgdir}" install
install -D -m0644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
- rmdir "${pkgdir}/usr/share/man/man5"
}