summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorluozengbin2015-10-08 16:53:23 +0900
committerluozengbin2015-10-08 16:53:23 +0900
commitf57a6a88398e0f72d012590547669b1e628b40ff (patch)
treeab6113e74b4c31a4fa49e39d4a3aa2f418ae5ead
downloadaur-f57a6a88398e0f72d012590547669b1e628b40ff.tar.gz
Initial import
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD49
-rw-r--r--Z99-zip-cp932.sh5
-rw-r--r--fc-init.patch4
-rw-r--r--file-roller.install13
5 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c258c1c83a15
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = file-roller-ja
+ pkgdesc = the file-roller with an additional patch to use unzip-iconv for unzip archive file cp932 charset.
+ pkgver = 3.16.3
+ pkgrel = 1
+ url = http://www.gnome.org
+ install = file-roller.install
+ arch = i686
+ arch = x86_64
+ groups = gnome-extra
+ license = GPL
+ makedepends = intltool
+ makedepends = pkg-config
+ makedepends = libnautilus-extension
+ makedepends = itstool
+ makedepends = docbook-xsl
+ depends = desktop-file-utils
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = dconf
+ depends = libarchive
+ depends = file
+ depends = json-glib
+ depends = libnotify
+ depends = zip
+ depends = unzip-iconv
+ optdepends = p7zip: 7z, arj, exe and encrypted zip files support
+ optdepends = unrar: better RAR archive support
+ optdepends = unace: ACE archive support
+ optdepends = lrzip: lrzip archive support
+ optdepends = cdrkit: ISO image support
+ provides = file-roller
+ conflicts = file-roller
+ options = !emptydirs
+ source = http://ftp.gnome.org/pub/gnome/sources/file-roller/3.16/file-roller-3.16.3.tar.xz
+ source = fc-init.patch
+ source = Z99-zip-cp932.sh
+ sha256sums = 2b3a1111caba26e67b96559a3118a700dbfb6a4c6ad7ebd3e509df227995411c
+ sha256sums = 27df085f1d6c8fad4bceb503267e767e7c43ad920f3cf9e91ee03e7f751addaf
+ sha256sums = 1ad7e934405a9c407a35d0e185503fff8f5f869156cc5598db1035c0900a89f0
+
+pkgname = file-roller-ja
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17b6e7fa9cca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Akira Wakana <jalen.cn@gmail.com>
+
+pkgname=file-roller-ja
+pkgver=3.16.3
+pkgrel=1
+provides=('file-roller')
+conflicts=('file-roller')
+pkgdesc="the file-roller with an additional patch to use unzip-iconv for unzip archive file cp932 charset."
+_pkgname=file-roller
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('desktop-file-utils' 'gtk3' 'hicolor-icon-theme' 'dconf' 'libarchive' 'file' 'json-glib' 'libnotify' 'zip' 'unzip-iconv')
+makedepends=('intltool' 'pkg-config' 'libnautilus-extension' 'itstool' 'docbook-xsl')
+optdepends=('p7zip: 7z, arj, exe and encrypted zip files support'
+ 'unrar: better RAR archive support'
+ 'unace: ACE archive support'
+ 'lrzip: lrzip archive support'
+ 'cdrkit: ISO image support')
+groups=('gnome-extra')
+options=('!emptydirs')
+install=file-roller.install
+url="http://www.gnome.org"
+source=("http://ftp.gnome.org/pub/gnome/sources/$_pkgname/${pkgver:0:4}/$_pkgname-$pkgver.tar.xz"
+ 'fc-init.patch'
+ 'Z99-zip-cp932.sh')
+sha256sums=('2b3a1111caba26e67b96559a3118a700dbfb6a4c6ad7ebd3e509df227995411c'
+ '27df085f1d6c8fad4bceb503267e767e7c43ad920f3cf9e91ee03e7f751addaf'
+ '1ad7e934405a9c407a35d0e185503fff8f5f869156cc5598db1035c0900a89f0')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ patch src/fr-init.c < ../../fc-init.patch
+}
+
+build() {
+ cd $_pkgname-$pkgver
+
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --libexecdir=/usr/lib/file-roller \
+ --localstatedir=/var --disable-static \
+ --disable-schemas-compile
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -Dm644 ../../Z99-zip-cp932.sh "${pkgdir}/etc/profile.d/Z99-zip-cp932.sh"
+}
diff --git a/Z99-zip-cp932.sh b/Z99-zip-cp932.sh
new file mode 100644
index 000000000000..73a98a9b36bf
--- /dev/null
+++ b/Z99-zip-cp932.sh
@@ -0,0 +1,5 @@
+if [[ "$LANG" == *"ja"* ]]
+then
+ export UNZIP="-O cp932"
+ export ZIPINFO="-O cp932"
+fi
diff --git a/fc-init.patch b/fc-init.patch
new file mode 100644
index 000000000000..4296a22ea159
--- /dev/null
+++ b/fc-init.patch
@@ -0,0 +1,4 @@
+353a354
+> register_archive (FR_TYPE_COMMAND_ZIP);
+368d368
+< register_archive (FR_TYPE_COMMAND_ZIP);
diff --git a/file-roller.install b/file-roller.install
new file mode 100644
index 000000000000..8b17fa3d4103
--- /dev/null
+++ b/file-roller.install
@@ -0,0 +1,13 @@
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}