summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThorsten Müller2022-09-21 16:58:31 +0200
committerThorsten Müller2022-09-21 16:58:31 +0200
commit87d5fa90a325eaabc94b2333113932ad2355d750 (patch)
treebdf2355e438ecbcb7a69b2344cb25accdb666471
downloadaur-87d5fa90a325eaabc94b2333113932ad2355d750.tar.gz
new package of filebeat-oss binary
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
-rw-r--r--filebeat-oss.service15
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ac999b6c618
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = filebeat-oss-bin
+ pkgdesc = Data shippers for Elasticsearch
+ pkgver = 8.4.2
+ pkgrel = 1
+ url = https://www.elastic.co/products/beats
+ arch = x86_64
+ license = Apache
+ depends = glibc
+ conflicts = filebeat-oss
+ backup = etc/filebeat-oss/filebeat.yml,
+ backup = etc/filebeat-oss/fields.yml
+ source = https://artifacts.elastic.co/downloads/beats/filebeat/filebeat-8.4.2-linux-x86_64.tar.gz
+ source = filebeat-oss.service
+ sha512sums = 49efd6dabf501778520257e77d5cdd6f3e9254995a0c75fd083c9e0a090ccb060d82d8c2516f3b9d1f0c92fa95be3bb9106598dfeb92c51c81c6b29b5c5ba307
+ sha512sums = 405bc15510c0d39bbbf5f21db8eaa7b6a4032fd199c2115cfc6df23a32b072b40dffea524b9b779fbe624604b91d20e91d4e67e00e854ad5322ff9105609f779
+
+pkgname = filebeat-oss-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc17e5bcff98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Thorsten Müller
+
+pkgname=filebeat-oss-bin
+pkgver=8.4.2
+pkgrel=1
+pkgdesc='Data shippers for Elasticsearch'
+arch=('x86_64')
+url='https://www.elastic.co/products/beats'
+license=('Apache')
+depends=('glibc')
+conflicts=(filebeat-oss)
+source=("https://artifacts.elastic.co/downloads/beats/filebeat/filebeat-${pkgver}-linux-x86_64.tar.gz"
+ "filebeat-oss.service")
+sha512sums=('49efd6dabf501778520257e77d5cdd6f3e9254995a0c75fd083c9e0a090ccb060d82d8c2516f3b9d1f0c92fa95be3bb9106598dfeb92c51c81c6b29b5c5ba307'
+ '405bc15510c0d39bbbf5f21db8eaa7b6a4032fd199c2115cfc6df23a32b072b40dffea524b9b779fbe624604b91d20e91d4e67e00e854ad5322ff9105609f779')
+backup=('etc/filebeat-oss/filebeat.yml', 'etc/filebeat-oss/fields.yml')
+srcpath="filebeat-${pkgver}-linux-x86_64"
+
+package() {
+ install -Dm755 "${srcdir}/${srcpath}/filebeat" "${pkgdir}/usr/bin/filebeat"
+ install -Dm644 "${srcdir}/${srcpath}/filebeat.yml" "${pkgdir}/etc/filebeat-oss/filebeat.yml"
+ install -Dm644 "${srcdir}/${srcpath}/filebeat.reference.yml" "${pkgdir}/etc/filebeat-oss/filebeat.reference.yml"
+ install -Dm644 "${srcdir}/${srcpath}/fields.yml" "${pkgdir}/etc/filebeat-oss/fields.yml"
+ install -Dm644 "filebeat-oss.service" "${pkgdir}/usr/lib/systemd/system/filebeat-oss.service"
+}
diff --git a/filebeat-oss.service b/filebeat-oss.service
new file mode 100644
index 000000000000..022b86908b64
--- /dev/null
+++ b/filebeat-oss.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Filebeat OSS sends log files to Logstash or directly to Elasticsearch OSS or OpenSearch.
+Documentation=https://www.elastic.co/guide/en/beats/filebeat/7.12/index.html
+Wants=network-online.target
+After=network-online.target
+
+[Service]
+Environment="BEAT_LOG_OPTS=-e"
+Environment="BEAT_CONFIG_OPTS=-c /etc/filebeat-oss/filebeat.yml"
+Environment="BEAT_PATH_OPTS=-path.home /usr/share/filebeat-oss -path.config /etc/filebeat-oss -path.data /var/lib/filebeat-oss -path.logs /var/log/filebeat-oss"
+ExecStart=/usr/bin/filebeat-oss $BEAT_LOG_OPTS $BEAT_CONFIG_OPTS $BEAT_PATH_OPTS
+Restart=on-failure
+
+[Install]
+WantedBy=multi-user.target