summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Lorrillere2015-07-23 15:32:58 +0200
committerMaxime Lorrillere2015-07-23 15:32:58 +0200
commit9ddf13e9f104f26d23f67169febfdf404a48b62a (patch)
treebe4924220ba812b5a270b280b7d0f5c38ffae023
downloadaur-9ddf13e9f104f26d23f67169febfdf404a48b62a.tar.gz
Update to 1.4.9.1-3
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e99c9ca615cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = filebench
+ pkgdesc = FileBench is a framework of file system workloads for measuring and comparing file system performance
+ pkgver = 1.4.9.1
+ pkgrel = 2
+ url = http://filebench.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = CDDL
+ depends = perl
+ depends = libaio
+ depends = libtecla
+ options = docs
+ source = http://downloads.sourceforge.net/sourceforge/filebench/filebench-1.4.9.1.tar.gz
+ md5sums = e30a4feb78ce5e8224c7ec15fd337e42
+
+pkgname = filebench
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bfb8bb3bac1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Luis Useche <useche@gmail.com>
+# Contributor: Hubert Kario <kario@wit.edu.pl>
+# Contributor: Maxime Lorrillere <maxime.lorrillere@gmail.com>
+
+pkgname=filebench
+pkgver=1.4.9.1
+pkgrel=2
+pkgdesc="FileBench is a framework of file system workloads for measuring and comparing file system performance"
+arch=(i686 x86_64)
+url="http://filebench.sourceforge.net"
+license=('CDDL')
+depends=(perl libaio libtecla)
+options=(docs)
+install=
+source=(http://downloads.sourceforge.net/sourceforge/filebench/$pkgname-$pkgver.tar.gz)
+md5sums=('e30a4feb78ce5e8224c7ec15fd337e42')
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: