summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhashworks2020-03-24 17:04:30 +0100
committerhashworks2020-03-24 17:04:30 +0100
commit80982409530a309205961a1c569834f185c0a145 (patch)
treece52b9335429992163762e0571ad96e48c4ddbe1
parent77e86f64fee34e4b4481d88f952a51f47a37be75 (diff)
downloadaur-80982409530a309205961a1c569834f185c0a145.tar.gz
Remove existing memcached config before symlink creation
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bf7486be2b89..9bfbd4aa244c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ url="https://wiki.server-speed.net/projects/filebin"
license=('AGPL')
makedepends=('nodejs' 'git')
depends=('php'
- 'pygmentize'
+ 'pygmentize'
'python-ansi2html'
'php-gd'
'imagemagick'
@@ -40,12 +40,13 @@ package() {
cp filebin-nginx.conf ${pkgdir}/usr/share/webapps/filebin
cd ${pkgdir}/usr/share/webapps/filebin
cp application/config/example/{config-local,database,memcached}.php ${pkgdir}/etc/webapps/filebin
+ rm application/config/memcached.php
ln -s /etc/webapps/filebin/{config-local,database,memcached}.php application/config
cp data/local/examples/contact-info.php ${pkgdir}/etc/webapps/filebin
ln -s /etc/webapps/filebin/contact-info.php data/local
# removing unnecessary data for a production environment
- rm -rf .git
+ rm -rf .git
rm -rf application/third_party/{test-more-php,mockery}
rm -rf application/tests
find . -name \*.gitignore -type f -delete