summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormax.bra2016-03-13 13:28:01 +0100
committermax.bra2016-03-13 13:28:01 +0100
commit4359a6b1bb9b0451406998b393d5de18ab92ab33 (patch)
treecd1e8e83d2adeac8c8c07636ae765f8e8a0d62ab
parent7fe75c1b551690162d1f8ac2e1655405abc4388e (diff)
downloadaur-4359a6b1bb9b0451406998b393d5de18ab92ab33.tar.gz
several adjustments from upstream (e.g. Apache common VFS is now used for archives), corrected optional 7zip java binding not loaded
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
-rw-r--r--filebot-arch.sh11
3 files changed, 18 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 793b8fcb3302..444d531ee0d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
+# Generated by mksrcinfo v8
+# Sun Mar 13 12:28:01 UTC 2016
pkgbase = filebot
pkgdesc = The ultimate tool to rename TV/anime shows, download subtitles, and validate checksums
pkgver = 4.6.1
- pkgrel = 1
+ pkgrel = 2
url = http://filebot.sourceforge.net/
arch = any
license = GPL
depends = java-runtime>=8
depends = fontconfig
+ depends = chromaprint
optdepends = libzen: Support for additional subtitle search engines (Sublight)
optdepends = libmediainfo: Episode naming / Sublight usage
optdepends = java-p7zip-binding: Extract archives
@@ -15,7 +18,7 @@ pkgbase = filebot
source = filebot.svg
source = filebot.desktop
md5sums = 29845bf89eeeab2c6e7c6669ea034876
- md5sums = 1d5dcc2c4a045830e59c705e29c99d18
+ md5sums = f9469bf391160033df1a7961fd732141
md5sums = 04f46be047049448dba3f0de29fe192d
md5sums = f37edd0bba7570904d28ab1681c7a7f3
diff --git a/PKGBUILD b/PKGBUILD
index a54aab2b5657..5ff25c3ed882 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,17 +5,17 @@
pkgname=filebot
pkgver=4.6.1
-pkgrel=1
+pkgrel=2
pkgdesc="The ultimate tool to rename TV/anime shows, download subtitles, and validate checksums"
arch=('any')
url="http://filebot.sourceforge.net/"
license=('GPL')
-depends=('java-runtime>=8' 'fontconfig')
+depends=('java-runtime>=8' 'fontconfig' 'chromaprint')
source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname/FileBot_$pkgver/FileBot_$pkgver-portable.zip
$pkgname-arch.sh $pkgname.svg $pkgname.desktop)
md5sums=('29845bf89eeeab2c6e7c6669ea034876'
- '1d5dcc2c4a045830e59c705e29c99d18'
+ 'f9469bf391160033df1a7961fd732141'
'04f46be047049448dba3f0de29fe192d'
'f37edd0bba7570904d28ab1681c7a7f3')
#noextract=(FileBot_$pkgver.jar)
diff --git a/filebot-arch.sh b/filebot-arch.sh
index 322c25d9e76c..9b8f2e649d2f 100644
--- a/filebot-arch.sh
+++ b/filebot-arch.sh
@@ -1,3 +1,12 @@
#!/bin/bash
-java -Dunixfs=false -DuseGVFS=false -DuseExtendedFileAttributes=true -DuseCreationDate=false -Dfile.encoding=UTF-8 -Djava.net.useSystemProxies=true -Dsun.net.client.defaultConnectTimeout=10000 -Dsun.net.client.defaultReadTimeout=60000 -Djna.nosys=true -Dapplication.deployment=aur -Dapplication.update=skip -Dapplication.dir=$HOME/.filebot -Djava.io.tmpdir=$HOME/.filebot/temp -Djna.library.path=/usr/share/java/filebot -Djava.library.path=/usr/share/java/filebot -jar /usr/share/java/filebot/filebot.jar "$@"
+# force JVM language and encoding settings
+export LANG="en_US.UTF-8"
+export LC_ALL="en_US.UTF-8"
+
+# FileBot settings
+# EXTRACTOR="SevenZipNativeBindings" # use the lib7-Zip-JBinding.so native library
+# EXTRACTOR="SevenZipExecutable" # use the 7z executable
+EXTRACTOR="ApacheVFS" # use Apache Commons VFS2 with junrar plugin
+
+java $JAVA_OPTS -Dunixfs=false -DuseGVFS=false -DuseExtendedFileAttributes=true -DuseCreationDate=false -Dfile.encoding="UTF-8" -Djava.net.useSystemProxies=true -Dsun.net.client.defaultConnectTimeout=10000 -Dsun.net.client.defaultReadTimeout=60000 -Djna.nosys=true -Dapplication.deployment=aur -Dapplication.update=skip -Dnet.filebot.Archive.extractor="$EXTRACTOR" -Dnet.filebot.AcoustID.fpcalc="fpcalc" -Dapplication.dir=$HOME/.filebot -Djava.io.tmpdir=/tmp/.filebot -Djna.library.path=/usr/share/java -jar /usr/share/java/filebot/filebot.jar "$@"