summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman2018-11-11 12:39:18 +0200
committerRoman2018-11-11 12:39:18 +0200
commit5c45d58ce591c091d3c50f2caefb99bf8762f6c1 (patch)
treecf6d5421e431139f27b2848272ed2d6cacc4ff8a
parent3c55f282b48b0cff89391e0d3952116edda3649e (diff)
downloadaur-5c45d58ce591c091d3c50f2caefb99bf8762f6c1.tar.gz
Changes to build and run with Java 8
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD16
-rw-r--r--filebot-arch.sh2
4 files changed, 21 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03d3b22cafda..ffb58895cdd3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = filebot
pkgdesc = The ultimate tool to rename TV/anime shows, download subtitles, and validate checksums.
pkgver = 4.8.4
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/filebot/filebot
install = filebot.install
arch = i686
@@ -12,8 +12,8 @@ pkgbase = filebot
license = GPL
makedepends = ant
makedepends = ivy
- makedepends = jdk>=8
- depends = java-runtime>=8
+ depends = java-openjfx
+ depends = jre8-openjdk
depends = fontconfig
depends = chromaprint
optdepends = libzen: Support for additional subtitle search engines (Sublight)
@@ -25,7 +25,7 @@ pkgbase = filebot
source = filebot.svg
source = filebot.desktop
md5sums = SKIP
- md5sums = abed3a5dab3032fcde08addbee04fb1b
+ md5sums = 7c1128f94fcd9f4e29225a12eac83704
md5sums = 04f46be047049448dba3f0de29fe192d
md5sums = f37edd0bba7570904d28ab1681c7a7f3
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..656715da99b3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.xz
+src/
+pkg/
+filebot/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 6398ee71fc03..fc07abff2fba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=filebot
pkgver=4.8.4
-pkgrel=3
+pkgrel=4
_jnaver=4.5.2
_fixedcommit=b9572f4501ba9d5af9d445a792fa902274f37679
pkgdesc="The ultimate tool to rename TV/anime shows, download subtitles, and validate checksums."
@@ -15,8 +15,8 @@ arch=('i686' 'x86_64' 'aarch64' 'armv7l' 'armv7h')
url="https://github.com/filebot/filebot"
license=('GPL')
install=$pkgname.install
-depends=('java-runtime>=8' 'fontconfig' 'chromaprint')
-makedepends=('ant' 'ivy' 'jdk>=8')
+depends=('java-openjfx' 'jre8-openjdk' 'fontconfig' 'chromaprint')
+makedepends=('ant' 'ivy')
[[ $CARCH == "i686" ]] && _intarch=i686
[[ $CARCH == "x86_64" ]] && _intarch=amd64
@@ -24,12 +24,14 @@ makedepends=('ant' 'ivy' 'jdk>=8')
[[ $CARCH == "armv7h" ]] && _intarch=armv7l
[[ $CARCH == "aarch64" ]] && _intarch=armv8
+_jre=$(archlinux-java get)
+
source=("${pkgname}::git+https://github.com/filebot/filebot.git"
#https://github.com/java-native-access/jna/archive/$_jnaver.tar.gz
$pkgname-arch.sh $pkgname.svg $pkgname.desktop)
md5sums=('SKIP'
- 'abed3a5dab3032fcde08addbee04fb1b'
+ '7c1128f94fcd9f4e29225a12eac83704'
'04f46be047049448dba3f0de29fe192d'
'f37edd0bba7570904d28ab1681c7a7f3')
@@ -64,8 +66,12 @@ EOT
build() {
cd $pkgname
+# print('Set system '+$_jre+' to java-9-openjdk. Should be reverted after build')
+ sudo archlinux-java set java-8-openjdk
ant resolve
ant jar
+# print('Reverting system Java to '+$_jre)
+# sudo archlinux-java set $_jre
}
package() {
@@ -75,4 +81,6 @@ package() {
install -Dm755 $pkgname-arch.sh "$pkgdir/usr/bin/$pkgname"
install -Dm644 $pkgname.svg "$pkgdir/usr/share/pixmaps/$pkgname.svg"
install -Dm644 $pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+
+ sudo archlinux-java set $_jre
}
diff --git a/filebot-arch.sh b/filebot-arch.sh
index 3c0fd15a1a79..b66e5028bbea 100644
--- a/filebot-arch.sh
+++ b/filebot-arch.sh
@@ -19,5 +19,5 @@ EXTRACTOR="ApacheVFS" # use Apache Commons VFS2 with junrar plugin
# EXTRACTOR="SevenZipNativeBindings" # use the lib7-Zip-JBinding.so native library
# start filebot
-java -Dunixfs=false -DuseGVFS=false -DuseExtendedFileAttributes=true -DuseCreationDate=false -Djava.net.useSystemProxies=false -Dapplication.deployment=AUR -Dfile.encoding="UTF-8" -Dsun.jnu.encoding="UTF-8" -Djna.nosys=false -Djna.nounpack=true -Dnet.filebot.Archive.extractor="$EXTRACTOR" -Dnet.filebot.AcoustID.fpcalc="fpcalc" -Dapplication.dir=$HOME/.config/filebot -Djava.io.tmpdir=/tmp/filebot -Dapplication.update=skip -Djna.library.path=/usr/share/java/filebot $JAVA_OPTS -cp /usr/share/java/filebot/filebot.jar net.filebot.Main "$@"
+/usr/lib/jvm/java-8-openjdk/bin/java -Dunixfs=false -DuseGVFS=false -DuseExtendedFileAttributes=true -DuseCreationDate=false -Djava.net.useSystemProxies=false -Dapplication.deployment=AUR -Dfile.encoding="UTF-8" -Dsun.jnu.encoding="UTF-8" -Djna.nosys=false -Djna.nounpack=true -Dnet.filebot.Archive.extractor="$EXTRACTOR" -Dnet.filebot.AcoustID.fpcalc="fpcalc" -Dapplication.dir=$HOME/.config/filebot -Djava.io.tmpdir=/tmp/filebot -Dapplication.update=skip -Djna.library.path=/usr/share/java/filebot $JAVA_OPTS -cp /usr/share/java/filebot/filebot.jar net.filebot.Main "$@"