summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman2018-11-17 21:27:23 +0200
committerRoman2018-11-17 21:27:23 +0200
commit2fed646934f0dd3acea6d601d3481d808826be1c (patch)
tree404255c2570a43779ac783efece43be6fb618a48
parentc998a8bcfe292fc28015c1e58520b45cabb8d2cd (diff)
downloadaur-2fed646934f0dd3acea6d601d3481d808826be1c.tar.gz
Will run under JRE
So JDK8 could be uninstalled after build
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD4
-rw-r--r--filebot-arch.sh2
3 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b67f9f12d91c..06df2c22a131 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = filebot-git
pkgdesc = The ultimate tool to rename TV/anime shows, download subtitles, and validate checksums.
pkgver = 4.8.4.r5853.20181001
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/filebot/filebot
install = filebot.install
arch = i686
@@ -12,6 +12,7 @@ pkgbase = filebot-git
license = GPL
makedepends = ant
makedepends = ivy
+ makedepends = jdk8-openjdk
depends = java-openjfx
depends = jre8-openjdk
depends = fontconfig
@@ -28,7 +29,7 @@ pkgbase = filebot-git
source = filebot.svg
source = filebot.desktop
md5sums = SKIP
- md5sums = 7c1128f94fcd9f4e29225a12eac83704
+ md5sums = a4cc7024a9c593abeb22a2511c96aef1
md5sums = 04f46be047049448dba3f0de29fe192d
md5sums = f37edd0bba7570904d28ab1681c7a7f3
diff --git a/PKGBUILD b/PKGBUILD
index cb7e064d89a6..137b065e09c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgname=filebot-git
_pkgname=filebot
pkgver=4.8.4.r5853.20181001
_pkgver=4.8.4
-pkgrel=1
+pkgrel=2
_jnaver=4.5.2
_fixedcommit=7a73521ceed9e015bc23b32c1abab2545a47adeb
@@ -38,7 +38,7 @@ source=("${_pkgname}::git+https://github.com/filebot/filebot.git"
$_pkgname-arch.sh $_pkgname.svg $_pkgname.desktop)
md5sums=('SKIP'
- '7c1128f94fcd9f4e29225a12eac83704'
+ 'a4cc7024a9c593abeb22a2511c96aef1'
'04f46be047049448dba3f0de29fe192d'
'f37edd0bba7570904d28ab1681c7a7f3')
diff --git a/filebot-arch.sh b/filebot-arch.sh
index b66e5028bbea..bc0ccdaf90ca 100644
--- a/filebot-arch.sh
+++ b/filebot-arch.sh
@@ -19,5 +19,5 @@ EXTRACTOR="ApacheVFS" # use Apache Commons VFS2 with junrar plugin
# EXTRACTOR="SevenZipNativeBindings" # use the lib7-Zip-JBinding.so native library
# start filebot
-/usr/lib/jvm/java-8-openjdk/bin/java -Dunixfs=false -DuseGVFS=false -DuseExtendedFileAttributes=true -DuseCreationDate=false -Djava.net.useSystemProxies=false -Dapplication.deployment=AUR -Dfile.encoding="UTF-8" -Dsun.jnu.encoding="UTF-8" -Djna.nosys=false -Djna.nounpack=true -Dnet.filebot.Archive.extractor="$EXTRACTOR" -Dnet.filebot.AcoustID.fpcalc="fpcalc" -Dapplication.dir=$HOME/.config/filebot -Djava.io.tmpdir=/tmp/filebot -Dapplication.update=skip -Djna.library.path=/usr/share/java/filebot $JAVA_OPTS -cp /usr/share/java/filebot/filebot.jar net.filebot.Main "$@"
+/usr/lib/jvm/java-8-openjdk/jre/bin/java -Dunixfs=false -DuseGVFS=false -DuseExtendedFileAttributes=true -DuseCreationDate=false -Djava.net.useSystemProxies=false -Dapplication.deployment=AUR -Dfile.encoding="UTF-8" -Dsun.jnu.encoding="UTF-8" -Djna.nosys=false -Djna.nounpack=true -Dnet.filebot.Archive.extractor="$EXTRACTOR" -Dnet.filebot.AcoustID.fpcalc="fpcalc" -Dapplication.dir=$HOME/.config/filebot -Djava.io.tmpdir=/tmp/filebot -Dapplication.update=skip -Djna.library.path=/usr/share/java/filebot $JAVA_OPTS -cp /usr/share/java/filebot/filebot.jar net.filebot.Main "$@"