summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraxionl2019-01-23 22:34:36 +0900
committeraxionl2019-01-23 22:34:36 +0900
commit55bf8b909899c8f52dcc6b71e3f1c79cfeb014a8 (patch)
treeefdd952a5b4e85249bc0bfae280c524cee1cd70a
parentf27bfc769322e83bfd0c2a663f0ce670a71001a4 (diff)
downloadaur-55bf8b909899c8f52dcc6b71e3f1c79cfeb014a8.tar.gz
[Fixed] filebrowser-bin: update the install file
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
-rw-r--r--config.json20
-rw-r--r--filebrowser-bin.install18
-rw-r--r--filebrowser@.service1
5 files changed, 25 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65da675622a4..0c93894bc562 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Thu Jan 10 03:11:53 UTC 2019
pkgbase = filebrowser-bin
pkgdesc = Web File Manager which can be used as a middleware or standalone app.
pkgver = 2.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/filebrowser/filebrowser
install = filebrowser-bin.install
arch = x86_64
@@ -11,14 +9,12 @@ pkgbase = filebrowser-bin
provides = filebrowser
conflicts = filebrowser
source = filebrowser@.service
- source = config.json
source = filebrowser-bin.install
source = https://raw.githubusercontent.com/hacdias/filebrowser/master/LICENSE
- sha256sums = a02170d454ca64905b1b5bfe00311afdac4da099eeb14f594e3be9d08bc07af9
- sha256sums = 211e8101821612d9c142ce05db565379845e735ec8f8891e3fa76111a65db799
- sha256sums = 82e9879a58d21f4ca4a28315f94ffdadfbbf461752e63252bf12b91de93bc9c8
+ sha256sums = 79a1fdb1f0b26f211242f1fdb6f3478a56890a721fe324ea7ade2e8f9a351b38
+ sha256sums = 8a423af0707ac37b15ca425ec097b3d98aecd08238f7599ae9dfcce31c8cbb32
sha256sums = 1fc20cab3a7d67d7997126a98dd151a362dc4600201ca37fd608b959d25985db
- source_x86_64 = https://github.com/filebrowser/filebrowser/releases/download/v2.0.0/linux-amd64-filebrowser.tar.gz
+ source_x86_64 = linux-amd64-filebrowser-2.0.0.tar.gz::https://github.com/filebrowser/filebrowser/releases/download/v2.0.0/linux-amd64-filebrowser.tar.gz
sha256sums_x86_64 = f52d849f8b4ca461ffd05c4fcdb5662c6c6acd75f79d2b0ed6bd38367779a38d
pkgname = filebrowser-bin
diff --git a/PKGBUILD b/PKGBUILD
index aa29e73a76e6..fb5183f37b30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Sherlock Holo <sherlockya(at)gmail.com>
pkgname=filebrowser-bin
pkgver=2.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Web File Manager which can be used as a middleware or standalone app."
arch=('x86_64')
url="https://github.com/filebrowser/filebrowser"
@@ -12,21 +12,19 @@ provides=("filebrowser")
conflicts=("filebrowser")
install="$pkgname.install"
-source=('filebrowser@.service' 'config.json' 'filebrowser-bin.install'
+source=('filebrowser@.service' 'filebrowser-bin.install'
'https://raw.githubusercontent.com/hacdias/filebrowser/master/LICENSE')
source_x86_64=(linux-amd64-filebrowser-$pkgver.tar.gz::https://github.com/filebrowser/filebrowser/releases/download/v$pkgver/linux-amd64-filebrowser.tar.gz)
-sha256sums=('a02170d454ca64905b1b5bfe00311afdac4da099eeb14f594e3be9d08bc07af9'
- '211e8101821612d9c142ce05db565379845e735ec8f8891e3fa76111a65db799'
- '82e9879a58d21f4ca4a28315f94ffdadfbbf461752e63252bf12b91de93bc9c8'
+sha256sums=('79a1fdb1f0b26f211242f1fdb6f3478a56890a721fe324ea7ade2e8f9a351b38'
+ '8a423af0707ac37b15ca425ec097b3d98aecd08238f7599ae9dfcce31c8cbb32'
'1fc20cab3a7d67d7997126a98dd151a362dc4600201ca37fd608b959d25985db')
sha256sums_x86_64=('f52d849f8b4ca461ffd05c4fcdb5662c6c6acd75f79d2b0ed6bd38367779a38d')
package() {
install -Dm644 filebrowser@.service ${pkgdir}/usr/lib/systemd/system/filebrowser@.service
- install -Dm644 config.json ${pkgdir}/etc/filebrowser/example.config.json
install -Dm755 LICENSE ${pkgdir}/usr/share/licenses/filebrowser-bin/LICENSE
install -Dm755 $srcdir/filebrowser ${pkgdir}/usr/bin/filebrowser
}
diff --git a/config.json b/config.json
deleted file mode 100644
index 09188cd654e3..000000000000
--- a/config.json
+++ /dev/null
@@ -1,20 +0,0 @@
-{
- "port": 8080,
- "noAuth": false,
- "baseURL": "/admin",
- "address": "127.0.0.1",
- "alternativeReCaptcha": false,
- "reCaptchaKey": "",
- "reCaptchaSecret": "",
- "database": "/usr/share/filebrowser/database.db",
- "log": "stdout",
- "plugin": "",
- "scope": "/usr/share/filebrowser/storage/",
- "allowCommands": true,
- "allowEdit": true,
- "allowNew": true,
- "commands": [
- "git",
- "svn"
- ]
-} \ No newline at end of file
diff --git a/filebrowser-bin.install b/filebrowser-bin.install
index c18a79cc7ddb..831bc4983e29 100644
--- a/filebrowser-bin.install
+++ b/filebrowser-bin.install
@@ -5,12 +5,26 @@ For the first time you need to initialize, for example:
-----------------------------------------------------------------------------
$ sudo mkdir -p /usr/share/filebrowser/storage
-$ sudo touch /usr/share/filebrowser/database.db
-$ sudo cp /etc/filebrowser/example.config.json /etc/filebrowser/config.json
+$ cd /usr/share/filebrowser/storage
+$ sudo filebrowser config init
+...(Setting your filebrowser)
+$ sudo filebrowser config export /etc/filebrowser/config.json
$ sudo systemctl enable --now filebrowser@config
-----------------------------------------------------------------------------
More: https://github.com/filebrowser/filebrowser
+ https://docs.filebrowser.xyz/
+"
+}
+
+post_upgrade() {
+ echo "
+If you upgrade the filebrowser from 1.x
+You must need to read the: https://docs.filebrowser.xyz/upgrade-from-1.x
+And the systemd unit and config file also need to be changed by yourself.
+
+More: https://github.com/filebrowser/filebrowser
+ https://docs.filebrowser.xyz/
"
}
diff --git a/filebrowser@.service b/filebrowser@.service
index d0d6609ee94a..b4e22d776995 100644
--- a/filebrowser@.service
+++ b/filebrowser@.service
@@ -5,6 +5,7 @@ Wants=network.target
[Service]
Type=simple
+WorkingDirectory=/usr/share/filebrowser
ExecStart=/usr/bin/filebrowser --config /etc/filebrowser/%i.json
Restart=on-failure