summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrik Karlsson2017-01-21 18:22:26 +0100
committerPatrik Karlsson2017-01-21 18:22:26 +0100
commita7e3bf08e7d394d595b6fc1debccf50964555a2d (patch)
treef9aadbef6d198191db83c4e2c003f9c1b3374cf8
downloadaur-a7e3bf08e7d394d595b6fc1debccf50964555a2d.tar.gz
1.0.0-1
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD45
-rw-r--r--filebydate.desktop8
-rwxr-xr-xfilebydate.sh10
5 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3692723c8774
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = filebydate
+ pkgdesc = organize files depending on their file or exif dates
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://trixon.se/projects/java/filebydate/
+ arch = any
+ license = Apache
+ makedepends = desktop-file-utils
+ depends = java-runtime=8
+ source = http://trixon.se/files/filebydate-1.0.0-bin.zip
+ source = filebydate.sh
+ source = filebydate.desktop
+ sha256sums = cc820a03e9e3415e2326d2f971a6dad7f681b9bed654adaec8c3a61665f191e4
+ sha256sums = c2597c42471798834798ddee7f9dcef7a0811b181b2f335699f131f2ccafeca0
+ sha256sums = 3fc348ada388e3dcb265a83837d3f264ff1ff1cc07973c42384d8cf928c2f2fd
+
+pkgname = filebydate
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..241e560df690
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c3e778cf583
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Patrik Karlsson <pata.karlsson@gmail.com>
+
+pkgname=filebydate
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="organize files depending on their file or exif dates"
+arch=('any')
+url="http://trixon.se/projects/java/filebydate/"
+license=('Apache')
+depends=('java-runtime=8')
+makedepends=('desktop-file-utils')
+source=(
+ "http://trixon.se/files/$pkgname-$pkgver-bin.zip"
+ 'filebydate.sh'
+ 'filebydate.desktop'
+)
+sha256sums=(
+ 'cc820a03e9e3415e2326d2f971a6dad7f681b9bed654adaec8c3a61665f191e4'
+ 'c2597c42471798834798ddee7f9dcef7a0811b181b2f335699f131f2ccafeca0'
+ '3fc348ada388e3dcb265a83837d3f264ff1ff1cc07973c42384d8cf928c2f2fd'
+)
+
+package() {
+ pushd "$srcdir/$pkgname-$pkgver"
+
+ # jars
+ install -d "$pkgdir/usr/share/java/filebydate"
+ find -name '*.jar' -execdir install -m644 {} "$pkgdir/usr/share/java/filebydate" \;
+
+ # icon
+ install -d "$pkgdir/usr/share/icons/hicolor/256x256/apps"
+ install -m644 filebydate.png "$pkgdir/usr/share/icons/hicolor/256x256/apps/filebydate.png"
+
+ popd
+
+ # launchers
+ install -Dm755 "$srcdir/filebydate.sh" "$pkgdir/usr/bin/filebydate"
+
+ # .desktop
+ desktop-file-install $pkgname.desktop --dir "$pkgdir/usr/share/applications/"
+
+ # remove version from filename
+ mv "$pkgdir/usr/share/java/filebydate/filebydate-${pkgver}.jar" "$pkgdir/usr/share/java/filebydate/filebydate.jar"
+}
+
diff --git a/filebydate.desktop b/filebydate.desktop
new file mode 100644
index 000000000000..9ffffe9f40f6
--- /dev/null
+++ b/filebydate.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=filebydate
+Exec=/usr/bin/filebydate
+Icon=filebydate
+Categories=System;
+Keywords=organize;date;photo
diff --git a/filebydate.sh b/filebydate.sh
new file mode 100755
index 000000000000..3cff626e297f
--- /dev/null
+++ b/filebydate.sh
@@ -0,0 +1,10 @@
+#!/bin/sh
+if ! /usr/bin/java -version 2>&1 | grep 'version "1.8' >/dev/null
+then
+ echo "filebydate requires Java 8" >&2
+ exit 1
+fi
+
+#unset JAVA_TOOL_OPTIONS
+exec /usr/bin/java -jar '/usr/share/java/filebydate/filebydate.jar' "$@"
+