summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoe2017-01-11 12:00:03 +0100
committerzoe2017-01-11 12:00:03 +0100
commit13b98240f458510067a1c0160c6946a3a845c45c (patch)
tree530bee15e23d72f3a8639af2860c308bd5e5fdd5
downloadaur-13b98240f458510067a1c0160c6946a3a845c45c.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
-rw-r--r--filecast.desktop11
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73cd23bb77b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed Jan 11 10:59:03 UTC 2017
+pkgbase = filecast
+ pkgdesc = Zero setup, cross platform desktop to mobile file transfer tool with GUI
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.onyxbits.de/filecast
+ arch = any
+ license = Apache
+ depends = java-environment
+ noextract = filecast-1.0.jar
+ source = filecast.desktop
+ source = https://github.com/onyxbits/FileCast/raw/master/src/main/resources/appicon-64.png
+ source = http://www.onyxbits.de/sites/default/files/download/339/filecast-1.0.jar
+ md5sums = b728f63da5204098d15b9b189d15082a
+ md5sums = 415293972a77a101ddf2392618d85b74
+ md5sums = ae0bb15e5669d16b551c49474dcc2d36
+
+pkgname = filecast
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a3f4583a66a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: zoe <chp321 at gmail dot com>
+pkgname=filecast
+pkgver=1.0
+pkgrel=1
+arch=('any')
+pkgdesc="Zero setup, cross platform desktop to mobile file transfer tool with GUI"
+url="http://www.onyxbits.de/filecast"
+license=('Apache')
+depends=('java-environment')
+source=('filecast.desktop'
+ "https://github.com/onyxbits/FileCast/raw/master/src/main/resources/appicon-64.png"
+ "http://www.onyxbits.de/sites/default/files/download/339/${pkgname}-${pkgver}.jar")
+noextract=("${pkgname}-${pkgver}.jar")
+md5sums=('b728f63da5204098d15b9b189d15082a' #filecast.desktop
+ '415293972a77a101ddf2392618d85b74' #appicon-64.png
+ 'ae0bb15e5669d16b551c49474dcc2d36') #${pkgname}-${pkgver}.jar
+
+package() {
+ # install files to java shared dir
+ mkdir -p "$pkgdir/usr/share/java/$pkgname"
+ install -Dm644 ${pkgname}-${pkgver}.jar "$pkgdir/usr/share/java/$pkgname"
+
+ # install icon and desktop database entry
+ install -Dm644 appicon-64.png "$pkgdir/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 ${pkgname}.desktop "$pkgdir/usr/share/applications/${pkgname}.desktop"
+
+ # starter
+ mkdir -p "$pkgdir/usr/bin"
+ cat > "$pkgdir/usr/bin/filecast" << \here
+#!/bin/sh
+exec java -Dawt.useSystemAAFontSettings=on -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel -Dfilecast.home="$HOME/.Filecast" -jar /usr/share/java/filecast/filecast-pkgver.jar "$@"
+exit $?
+here
+ sed -i "s/pkgver/${pkgver}/" "$pkgdir/usr/bin/${pkgname}"
+ chmod a+x "${pkgdir}/usr/bin/${pkgname}"
+}
+
diff --git a/filecast.desktop b/filecast.desktop
new file mode 100644
index 000000000000..e1e0bd129bc8
--- /dev/null
+++ b/filecast.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Filecast
+Comment=Zero setup, cross platform desktop to mobile file transfer tool
+Categories=Qt;KDE;GNOME;Application;Java
+Type=Application
+StartupNotify=true
+TryExec=/usr/bin/filecast
+Exec=filecast
+Icon=/usr/share/pixmaps/filecast.png
+Terminal=false