summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaultDon2015-07-02 10:16:34 -0700
committerSaultDon2015-07-02 10:16:34 -0700
commit057bf0b07400e9438bba4e0783d1373f05f76039 (patch)
tree9ebdb02b80c8f07dbe77aee3b639571cfd1a1a0c
downloadaur-057bf0b07400e9438bba4e0783d1373f05f76039.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD72
-rw-r--r--filegdb-api.changelog15
-rw-r--r--filegdb-api.install5
4 files changed, 109 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b715f64e7d39
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = filegdb-api
+ pkgdesc = ESRI File Geodatabase (FileGDB) API
+ pkgver = 1.3
+ pkgrel = 2
+ url = http://www.esri.com/apps/products/download/#File_Geodatabase_API_1.3
+ install = filegdb-api.install
+ changelog = filegdb-api.changelog
+ arch = i686
+ arch = x86_64
+ license = custom:"ESRI - User Restrictions"
+ makedepends = libxml2
+ makedepends = gcc>=3.4.6
+ optdepends = gdal-filegdb: wrapper
+ noextract = filegdb-api-1.3.tar.gz
+
+pkgname = filegdb-api
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e87b258e9efc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,72 @@
+# Maintainer: SaultDon <sault.don gmail>
+pkgname=filegdb-api
+_pkgname=FileGDB_API
+pkgver=1.3
+pkgrel=2
+pkgdesc="ESRI File Geodatabase (FileGDB) API"
+arch=('i686' 'x86_64')
+url="http://www.esri.com/apps/products/download/#File_Geodatabase_API_1.3"
+license=('custom:"ESRI - User Restrictions"')
+makedepends=('libxml2' 'gcc>=3.4.6')
+optdepends=('gdal-filegdb: wrapper')
+changelog=$pkgname.changelog
+install=$pkgname.install
+case $CARCH in
+i686)
+ source=($pkgname-$pkgver.tar.gz::http://downloads2.esri.com/Software/${_pkgname}_${pkgver//./_}-32.tar.gz)
+ md5sums=('f54739d309436f96d0a23149bf08ac53')
+ ;;
+x86_64)
+ source=($pkgname-$pkgver.tar.gz::http://downloads2.esri.com/Software/${_pkgname}_${pkgver//./_}-64.tar.gz)
+ md5sums=('167ed3d756ad961c0849a9387f4be733')
+ ;;
+esac
+noextract=($pkgname-$pkgver.tar.gz)
+
+build() {
+ tar xzvf $pkgname-$pkgver.tar.gz
+
+ #Build for linux
+ export CPPFLAGS=-Dlinux
+
+ #Setup LD_LIBRARY_PATH
+ export LD_LIBRARY_PATH=$srcdir/${_pkgname}/lib:$LD_LIBRARY_PATH
+
+ #Building all samples
+ cd "$srcdir/${_pkgname}/samples"
+ make
+
+ # Building ProcessTopology
+ cd "$srcdir/${_pkgname}/samples/ProcessTopologies"
+
+ # Insert libxml2 library path to Makefile
+ sed -i '/^CXXFLAGS=/ s/$/ -I\/usr\/include\/libxml2\//' Makefile
+ make
+}
+
+# Uncomment check() portion if you want to perform sample tests
+# Warning: Lots of verbose output for tests!
+#
+#check() {
+# cd "$srcdir/${_pkgname}/samples/bin"
+# for i in *
+# do
+# ./${i}
+# done
+#}
+
+package() {
+ mkdir -p $pkgdir/usr/{lib,include,share/{doc,licenses}}/$pkgname
+ mkdir -p $pkgdir/usr/lib/$pkgname/{lib,include}
+ mkdir -p $pkgdir/etc/ld.so.conf.d
+ install -Dm644 $srcdir/${_pkgname}/license/* "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 $srcdir/${_pkgname}/lib/* "$pkgdir/usr/lib/$pkgname/lib/"
+ install -Dm644 $srcdir/${_pkgname}/include/* "$pkgdir/usr/lib/$pkgname/include/"
+ cp -r $srcdir/${_pkgname}/doc/html "$pkgdir/usr/share/doc/$pkgname/"
+ echo "/usr/lib/$pkgname/lib" > $pkgdir/etc/ld.so.conf.d/$pkgname.conf
+ find $pkgdir/usr/share/doc/$pkgname/ -type d -exec chmod 755 '{}' \;
+ find $pkgdir/usr/share/doc/$pkgname/ -type f -exec chmod 644 '{}' \;
+ chown root: $pkgdir/usr/share/doc/$pkgname/*
+ chmod 644 $pkgdir/etc/ld.so.conf.d/$pkgname.conf
+ chown root: $pkgdir/etc/ld.so.conf.d/$pkgname.conf
+}
diff --git a/filegdb-api.changelog b/filegdb-api.changelog
new file mode 100644
index 000000000000..6602a849d096
--- /dev/null
+++ b/filegdb-api.changelog
@@ -0,0 +1,15 @@
+2013-03-18 SaultDon <sault.don gmail>
+
+ * 1.3-2 :
+ - added CPPFLAGS export for linux builds, thanks marcelhuber
+
+2013-14-09 Saultdon <sault.don gmail>
+
+ * 1.3-0.143 :
+ - updated pkgrel to match API "Build Version" found in README
+ - added gcc to makedepends
+
+2013-12-09 SaultDon <sault.don gmail>
+
+ * 1.3-0 :
+ - sources updated to ESRI FileGDB API 1.3
diff --git a/filegdb-api.install b/filegdb-api.install
new file mode 100644
index 000000000000..6b688acc6c6c
--- /dev/null
+++ b/filegdb-api.install
@@ -0,0 +1,5 @@
+post_install() {
+ sbin/ldconfig
+ echo "## Please see the ESRI license agreements installed to /usr/share/licenses/filegdb-api"
+ echo "## See license agreements userrestrictions.txt and E204_E300.pdf"
+}