summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-06-03 18:56:40 -0700
committerxiota2023-06-03 18:56:40 -0700
commit21dea1ec0d2ddd8dcd9d5f0e1699b725515e2a26 (patch)
tree138bd8c0c8a08ca85cc13b2e9592063fd25ed46b
parente3f8be07f91c8db9b7b788c2d0ff31e0655d652d (diff)
downloadaur-21dea1ec0d2ddd8dcd9d5f0e1699b725515e2a26.tar.gz
update depends, pkgver, build, package
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD83
3 files changed, 66 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffe33d5d3132..ca643372dfb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = filelight-git
pkgdesc = View disk usage information
- pkgver = r915.7ec619e
+ pkgver = 23.04.2.r0.g2f2b5a1
pkgrel = 1
- url = https://projects.kde.org/projects/kde/applications/filelight
+ url = https://invent.kde.org/utilities/filelight
arch = i686
arch = x86_64
license = GPL
@@ -11,12 +11,14 @@ pkgbase = filelight-git
makedepends = extra-cmake-modules
makedepends = git
makedepends = kdoctools
- depends = kio
depends = hicolor-icon-theme
+ depends = kdeclarative
+ depends = kio
+ depends = kquickcharts
+ depends = qqc2-desktop-style
provides = filelight
conflicts = filelight
- source = git+https://invent.kde.org/utilities/filelight.git
- md5sums = SKIP
+ source = filelight::git+https://invent.kde.org/utilities/filelight
+ sha256sums = SKIP
pkgname = filelight-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 2dc19d90f262..af21a5e5e74b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,72 @@
-# Maintainer: Martin Sandsmark <martin.sandsmark@kde.org>
+# Maintainer:
+# Contributor: Martin Sandsmark <martin.sandsmark@kde.org>
-pkgname=filelight-git
-pkgver=r915.7ec619e
+_pkgname="filelight"
+pkgname="$_pkgname-git"
+pkgver=23.04.2.r0.g2f2b5a1
pkgrel=1
pkgdesc="View disk usage information"
arch=('i686' 'x86_64')
-url='https://projects.kde.org/projects/kde/applications/filelight'
+url='https://invent.kde.org/utilities/filelight'
license=('GPL' 'LGPL' 'FDL')
-depends=('kio' 'hicolor-icon-theme')
-makedepends=('extra-cmake-modules' 'git' 'kdoctools')
-provides=('filelight')
-conflicts=('filelight')
-source=('git+https://invent.kde.org/utilities/filelight.git')
-md5sums=('SKIP')
+
+depends=(
+ 'hicolor-icon-theme'
+ 'kdeclarative'
+ 'kio'
+ 'kquickcharts'
+ 'qqc2-desktop-style'
+)
+makedepends=(
+ 'extra-cmake-modules'
+ 'git'
+ 'kdoctools'
+)
+
+provides=("$_pkgname")
+conflicts=(${provides[@]})
+
+source=(
+ "$_pkgname"::"git+$url"
+)
+sha256sums=(
+ 'SKIP'
+)
pkgver() {
- cd filelight
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
+ cd "$srcdir/$_pkgname"
+
+ _regex='^\s+<release version="([0-9]+\.[0-9]+(\.[0-9]+)?)".*>$'
+ _file='misc/org.kde.filelight.appdata.xml'
+
+ _line=$(
+ grep -E "$_regex" "$_file" | head -1
+ )
+ _version=$(
+ echo "$_line" | sed -E "s@$_regex@\1@"
+ )
+ _commit=$(
+ git log -S "$_line" -1 --pretty=oneline --no-color | sed 's@\ .*$@@'
+ )
+ _revision=$(
+ git rev-list --count $_commit..HEAD
+ )
+ _hash=$(
+ git rev-parse --short HEAD
+ )
-prepare() {
- mkdir -p build
+ echo "$_version.r$_revision.g$_hash"
}
build() {
- cd build
- BUILD_TYPE=Release
- if [[ " ${OPTIONS[@]} " =~ " debug " ]]; then
- BUILD_TYPE=RelDebug
- elif [[ " ${OPTIONS[@]} " =~ " !strip " ]]; then
- BUILD_TYPE=RelDebug
- fi
- echo "${BUILD_TYPE}"
-
- cmake ../filelight \
- -DCMAKE_BUILD_TYPE=${BUILD_TYPE} \
+ cmake -B build -S $pkgname-$pkgver \
+ -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DKDE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
- make
+ cmake --build build
}
package() {
- cd build
- make DESTDIR="${pkgdir}" install
+ DESTDIR="$pkgdir" cmake --install build
}