summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle2018-02-23 23:40:18 -0500
committerKyle2018-02-23 23:40:18 -0500
commit90f5e71b5fd7257139e822790d516b32f9d48eab (patch)
tree03762809dd3a3c861ee8222480924111b2989b11
downloadaur-90f5e71b5fd7257139e822790d516b32f9d48eab.tar.gz
initial release
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3fc089a887e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Sat Feb 24 04:39:22 UTC 2018
+pkgbase = files-f123light-git
+ pkgdesc = System and user configuration files, scripts and other files specific to F123Light, an ArchLinuxARM-based operating system for the Raspberry Pi 2 and 3
+ pkgver = 0.0
+ pkgrel = 1
+ url = http://f123.org
+ arch = any
+ license = GPL3
+ makedepends = git
+ source = git+https://github.com/F123/Files-F123Light.git
+ md5sums = SKIP
+
+pkgname = files-f123light-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86d09b47f8b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Kyle <kyle@gmx.ca>
+pkgname=files-f123light-git
+_gitname=files-F123Light
+pkgver=0.0 # automatically determined from git origin
+pkgrel=1
+pkgdesc="System and user configuration files, scripts and other files specific to F123Light, an ArchLinuxARM-based operating system for the Raspberry Pi 2 and 3"
+arch=(any)
+url="http://f123.org"
+license=('GPL3')
+depends=
+makedepends=('git')
+provides=
+conflicts=
+options=
+source=('git+https://github.com/F123/Files-F123Light.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ # Use the tag of the last commit
+ git describe --always | sed -e 's|v||' -e 's|-|.|g'
+}
+
+package() {
+ cd $_gitname
+ cp -a files/* $pkgdir
+}
+
+# vim:set ts=2 sw=2 et: