summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhayao2021-06-06 22:23:34 +0900
committerhayao2021-06-06 22:23:34 +0900
commit0674eed20e959fd44513d4bd3068447bd2159556 (patch)
tree584ceb41619ad52b2b2ca304efad1feeada7eaf7
parent9cf6d23ccf565a1740ae32c3b8c80199ce668473 (diff)
downloadaur-0674eed20e959fd44513d4bd3068447bd2159556.tar.gz
[fix] : Fixed conflicts , provides, souces and checksums
I'm making this change as the package may be removed again, but honestly I don't think these changes make sense.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 17 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23ed72fac6ef..a262229a18a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = filezilla-bin
pkgdesc = Free, open source FTP, FTPS and SFTP client (Pre-built binary)
pkgver = 3.54.1
- pkgrel = 1
+ pkgrel = 2
url = https://filezilla-project.org
arch = i686
arch = x86_64
license = GPL
- makedepends = curl
depends = pugixml
depends = wxgtk3
depends = xdg-utils
@@ -15,13 +14,10 @@ pkgbase = filezilla-bin
depends = nettle
depends = sqlite
provides = filezilla
- provides = filezilla-git
conflicts = filezilla
- conflicts = filezilla-git
- conflicts = libfilezilla
- source_i686 = FileZilla_3.54.1_i686-linux-gnu.tar.bz2::https://download.filezilla-project.org/client/FileZilla_3.54.1_i686-linux-gnu.tar.bz2
- sha512sums_i686 = SKIP
- source_x86_64 = FileZilla_3.54.1_x86_64-linux-gnu.tar.bz2::https://download.filezilla-project.org/client/FileZilla_3.54.1_x86_64-linux-gnu.tar.bz2
- sha512sums_x86_64 = SKIP
+ source_i686 = https://download.filezilla-project.org/client/FileZilla_3.54.1_i686-linux-gnu.tar.bz2
+ sha512sums_i686 = f0f5c54e9e3d630b75f353a1bde8da40eee1a24deb3ae3663cb1c2a9c5946e96bdd7fbdedc6fd259fa4a3665968960dec241dd7301b489306bc9f1dcf40262f1
+ source_x86_64 = https://download.filezilla-project.org/client/FileZilla_3.54.1_x86_64-linux-gnu.tar.bz2
+ sha512sums_x86_64 = 034cb3a2d7258437e3a8b2193c342f818183bf25388b83cb1f5a7b4f81dbe27c67f1d32b5060de60628147ff214fbe0d2f392d4294c7ecbca9d3bcc701da0029
pkgname = filezilla-bin
diff --git a/PKGBUILD b/PKGBUILD
index d1289ec5326d..f767ad5b7622 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
# Maintainer: Yamada Hayao <hayao@fascode.net>
_pkgname="filezilla"
-pkgname="$_pkgname-bin"
+pkgname="${_pkgname}-bin"
pkgver="3.54.1"
-pkgrel=1
+pkgrel="2"
pkgdesc='Free, open source FTP, FTPS and SFTP client (Pre-built binary)'
arch=('i686' 'x86_64')
url='https://filezilla-project.org'
license=('GPL')
depends=('pugixml' 'wxgtk3' 'xdg-utils' 'gmp' 'gnutls' 'nettle' 'sqlite')
-makedepends=('curl')
-provides=("${_pkgname}" "${_pkgname}-git")
-conflicts=("${_pkgname}" "${_pkgname}-git" "libfilezilla")
-machine_arch="${CARCH}"
-
-for _arch in ${arch[@]}; do
- eval "source_${_arch}=(FileZilla_${pkgver}_${_arch}-linux-gnu.tar.bz2::https://download.filezilla-project.org/client/FileZilla_${pkgver}_${_arch}-linux-gnu.tar.bz2)"
- eval "sha512sums_${_arch}=(SKIP)"
-done
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+# x86_64
+source_x86_64=("https://download.filezilla-project.org/client/FileZilla_${pkgver}_x86_64-linux-gnu.tar.bz2")
+sha512sums_x86_64=('034cb3a2d7258437e3a8b2193c342f818183bf25388b83cb1f5a7b4f81dbe27c67f1d32b5060de60628147ff214fbe0d2f392d4294c7ecbca9d3bcc701da0029')
+
+# i686
+source_i686=("https://download.filezilla-project.org/client/FileZilla_${pkgver}_i686-linux-gnu.tar.bz2")
+sha512sums_i686=('f0f5c54e9e3d630b75f353a1bde8da40eee1a24deb3ae3663cb1c2a9c5946e96bdd7fbdedc6fd259fa4a3665968960dec241dd7301b489306bc9f1dcf40262f1')
package() {