summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhayao2021-03-30 10:32:23 +0900
committerhayao2021-03-30 10:32:23 +0900
commit58b5a6d546042f58ff0394d687ce2691e0b203f8 (patch)
treea0267c9a58d0ae27e5e3655c8d4eb1caa8447d28
parent58d84f9b13cb318db9ca5bedf466950e50b321ac (diff)
downloadaur-58b5a6d546042f58ff0394d687ce2691e0b203f8.tar.gz
[update] : Updated 3.53.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06a976fa1b08..80806273427d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = filezilla-bin
pkgdesc = Free, open source FTP, FTPS and SFTP client (Pre-built binary)
- pkgver = 3.53.0
+ pkgver = 3.53.1
pkgrel = 1
url = https://filezilla-project.org
arch = i686
@@ -19,10 +19,10 @@ pkgbase = filezilla-bin
conflicts = filezilla
conflicts = filezilla-git
conflicts = libfilezilla
- source_i686 = FileZilla_3.53.0_i686-linux-gnu.tar.bz2::https://download.filezilla-project.org/client/FileZilla_3.53.0_i686-linux-gnu.tar.bz2
- sha512sums_i686 = 33e277e9b704e2bc53d9bc519bbae691430d99f9d3053bf2667f4a5791d8533abffef97334e60e649a37a7153c23c206513758e5c1ce23741c87a022b330871b
- source_x86_64 = FileZilla_3.53.0_x86_64-linux-gnu.tar.bz2::https://download.filezilla-project.org/client/FileZilla_3.53.0_x86_64-linux-gnu.tar.bz2
- sha512sums_x86_64 = c559215b425b732e6293daa70c0d59727f3d9d6cc22afd5f1e08365d162e300cd0ba1a054df71780ee147cce8578ac7d525382abfc83da79f6318561599912f9
+ source_i686 = FileZilla_3.53.1_i686-linux-gnu.tar.bz2::https://download.filezilla-project.org/client/FileZilla_3.53.1_i686-linux-gnu.tar.bz2
+ sha512sums_i686 = 93bb1dfc788258cbf797534e20d58aae79716b3cf6526ce8a1e23479658ff2125ac74ad818c4001929104a021116bae6c9aed5cfe65fe15a60fbf54befb23e4e
+ source_x86_64 = FileZilla_3.53.1_x86_64-linux-gnu.tar.bz2::https://download.filezilla-project.org/client/FileZilla_3.53.1_x86_64-linux-gnu.tar.bz2
+ sha512sums_x86_64 = 48cea5ee382164b28184812f8f8051d0ce5fe521dcc63e4d7b90f60ee8594c8422e0743e2566fe452939c5173c1f12945d71081cf96c30538b0140c156630f25
pkgname = filezilla-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1788a93de611..1e57ed12dc3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Yamada Hayao <hayao@fascode.net>
-_pkgname=filezilla
+_pkgname="filezilla"
pkgname="$_pkgname-bin"
-pkgver=3.53.0
+pkgver="3.53.1"
pkgrel=1
pkgdesc='Free, open source FTP, FTPS and SFTP client (Pre-built binary)'
arch=('i686' 'x86_64')
@@ -20,7 +20,7 @@ for _arch in ${arch[@]}; do
'$(
_url="https://download.filezilla-project.org/client/FileZilla_${pkgver}.sha512"
_sum="$(curl --silent -L "${_url}" | grep "FileZilla_${pkgver}_${_arch}-linux-gnu.tar.bz2")"
- if [[ ! "${?}" = 0 ]] || [[ ! -v "_sum" ]] || [[ -z "${_sum}" ]]; then
+ if [[ ! "${?}" = 0 ]] || [[ ! -v "_sum" ]] || [[ -z "${_sum}" ]] || [[ "${_sum}" = "" ]]; then
echo -n "SKIP"
else
echo -n "$(echo "${_sum}" | cut -d ' ' -f 1)"
@@ -30,9 +30,8 @@ for _arch in ${arch[@]}; do
done
package() {
- rm -rf "${srcdir}/FileZilla_${pkgver}_${machine_arch}-linux-gnu.tar.bz2"
mkdir -p "${pkgdir}/opt/" "${pkgdir}/usr/bin/"
- cp -r "${srcdir}/"* "${pkgdir}/opt/"
+ cp -r "${srcdir}/FileZilla3" "${pkgdir}/opt/"
mv "${pkgdir}/opt/FileZilla3/share" "${pkgdir}/usr/"
@@ -41,8 +40,9 @@ package() {
ln -s "${1}" "${2}"
echo "Created symlink ${1} -> ${2}"
}
+
for _fullpath in "${pkgdir}/opt/FileZilla3/bin/"* ;do
_filename="$(basename "${_fullpath}")"
- _make_link "/opt/FileZilla3/bin/${_filename}" "${pkgdir}/usr/bin/${_filename}"
+ _make_link "/opt/FileZilla3/bin/${_filename}" "${pkgdir}/usr/bin/${_filename}"
done
}