summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhayao2020-08-14 13:53:42 +0900
committerhayao2020-08-14 13:53:42 +0900
commita348e1bd8c8b0a92c2e84fd60396bf84747e3190 (patch)
tree6c978c611ccc8aef1146b64cb5cad406f37853a9
parentebf422a1ab55681ccd1ba8f8cf4532a2c7bfdc2b (diff)
downloadaur-a348e1bd8c8b0a92c2e84fd60396bf84747e3190.tar.gz
[fix] : download link
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD6
3 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 274cdc919195..f1c6a922ece8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = filezilla-bin
pkgdesc = Free, open source FTP, FTPS and SFTP client
pkgver = 3.49.1
- pkgrel = 1
+ pkgrel = 2
url = https://filezilla-project.org
arch = i686
arch = x86_64
@@ -16,7 +16,7 @@ pkgbase = filezilla-bin
depends = sqlite
provides = filezilla
conflicts = filezilla
- source = FileZilla_3.49.1_x86_64-linux-gnu.tar.bz2::https://dl3.cdn.filezilla-project.org/client/FileZilla_3.49.1_x86_64-linux-gnu.tar.bz2?h=B4YMUwovpvAXnVxTDxxU6w&x=1597378984
+ source = FileZilla_3.49.1_x86_64-linux-gnu.tar.bz2::https://download.filezilla-project.org/client/FileZilla_3.49.1_x86_64-linux-gnu.tar.bz2
sha512sums = 6de3f2f4f08bb6ec83cf0e40ca67504e0d25302700c5f7b5778a0d54d9741cf7a75ffb9085e8e6bdd648d2e6bbcd6f5cf1104b91fe80757ce1d3fe1aa7f48f83
pkgname = filezilla-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..effd59a896fe
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.pkg.tar.*
+pkg
+src \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 3e700aec9504..1f663b4fc590 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=filezilla
pkgname="$_pkgname-bin"
pkgver=3.49.1
-pkgrel=1
+pkgrel=2
pkgdesc='Free, open source FTP, FTPS and SFTP client'
arch=('i686' 'x86_64')
url='https://filezilla-project.org'
@@ -16,12 +16,12 @@ conflicts=("$_pkgname")
machine_arch=$(uname -m)
source=(
- "FileZilla_${pkgver}_${machine_arch}-linux-gnu.tar.bz2::https://dl3.cdn.filezilla-project.org/client/FileZilla_${pkgver}_${machine_arch}-linux-gnu.tar.bz2?h=B4YMUwovpvAXnVxTDxxU6w&x=1597378984"
+ "FileZilla_${pkgver}_${machine_arch}-linux-gnu.tar.bz2::https://download.filezilla-project.org/client/FileZilla_${pkgver}_${machine_arch}-linux-gnu.tar.bz2"
)
sha512sums=(
"$(
- _url='https://dl2.cdn.filezilla-project.org/client/FileZilla_3.49.1.sha512?h=Is3dK9yMEdrdZ_TqQmoXJA&x=1597380525'
+ _url='https://download.filezilla-project.org/client/FileZilla_3.49.1.sha512'
_sum=$(curl -L "${_url}" | grep "FileZilla_${pkgver}_${machine_arch}-linux-gnu.tar.bz2" | awk '{print $1}')
if [[ ! "${?}" = 0 ]] || [[ ! -v "_sum" ]]; then
echo -n "SKIP"