summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShai Jo2018-02-27 18:52:16 +0100
committerShai Jo2018-02-27 19:03:24 +0100
commit09e25138ccca8bf355157fa07a5b5438d47798f8 (patch)
treed4b6dec93511b223c875539081e6bf9c644f775b
downloadaur-filezilla-storj.tar.gz
copy filezilla community PKGBUILD, enable Storj support, change maintainer and generate .SRCINFO
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD40
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4aac19409217
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = filezilla-storj
+ pkgdesc = Fast and reliable Storj, FTP, FTPS and SFTP client
+ pkgver = 3.31.0
+ pkgrel = 1
+ url = http://filezilla-project.org/
+ arch = x86_64
+ license = GPL
+ depends = dbus
+ depends = xdg-utils
+ depends = wxgtk3
+ depends = libidn
+ depends = hicolor-icon-theme
+ depends = sqlite
+ depends = gnutls
+ depends = libfilezilla
+ depends = libstorj
+ provides = filezilla
+ conflicts = filezilla
+ source = http://downloads.sourceforge.net/project/filezilla/FileZilla_Client/3.31.0/FileZilla_3.31.0_src.tar.bz2
+ md5sums = 0eee1369904e9b0b60500a1068ca5a85
+
+pkgname = filezilla-storj
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7462210e28f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# $Id$
+# Contributor: Alexander Fehr <pizzapunk gmail com>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Maintainer: Shai Jo <shaiJo4U[äT]protonmail(.)com
+
+_pkgname=filezilla
+pkgname=$_pkgname-storj
+pkgver=3.31.0
+pkgrel=1
+pkgdesc="Fast and reliable Storj, FTP, FTPS and SFTP client"
+arch=('x86_64')
+url="http://filezilla-project.org/"
+license=('GPL')
+depends=('dbus' 'xdg-utils' 'wxgtk3' 'libidn' 'hicolor-icon-theme' 'sqlite' 'gnutls' 'libfilezilla' 'libstorj')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("http://downloads.sourceforge.net/project/filezilla/FileZilla_Client/${pkgver}/FileZilla_${pkgver}_src.tar.bz2")
+
+prepare() {
+ cd "${_pkgname}-${pkgver}"
+}
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ ./configure \
+ --prefix=/usr \
+ --disable-manualupdatecheck \
+ --disable-autoupdatecheck \
+ --with-pugixml=builtin \
+ --with-wx-config=/usr/bin/wx-config-gtk3 \
+ --enable-storj
+ make
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+
+md5sums=('0eee1369904e9b0b60500a1068ca5a85')