summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2016-01-13 14:39:09 +0100
committerPeter Mattern2016-01-13 14:39:09 +0100
commitfa056ec6af927894466f537dffc16fde5bb7429b (patch)
treeea8819be407916f8d53da60fffc2b793dec8ab0c
downloadaur-fa056ec6af927894466f537dffc16fde5bb7429b.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD34
-rw-r--r--filezilla-svn.install11
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..854c12d32d57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Wed Jan 13 11:52:16 UTC 2016
+pkgbase = filezilla-svn
+ pkgdesc = Free, open source FTP, FTPS and SFTP client
+ pkgver = 7250
+ pkgrel = 1
+ url = https://filezilla-project.org
+ install = filezilla-svn.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = subversion
+ depends = libfilezilla
+ depends = pugixml
+ depends = wxgtk
+ depends = xdg-utils
+ provides = filezilla
+ conflicts = filezilla
+ source = filezilla::svn+https://svn.filezilla-project.org/svn/FileZilla3/trunk
+ sha256sums = SKIP
+
+pkgname = filezilla-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd543f429575
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Peter Mattern <pmattern at arcor dot de>
+
+_pkgname=filezilla
+pkgname=$_pkgname-svn
+pkgver=7250
+pkgrel=1
+pkgdesc="Free, open source FTP, FTPS and SFTP client"
+arch=("i686" "x86_64")
+url="https://filezilla-project.org"
+license=("GPL")
+depends=("libfilezilla" "pugixml" "wxgtk" "xdg-utils")
+makedepends=("subversion")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+install=$pkgname.install
+source=("$_pkgname::svn+https://svn.filezilla-project.org/svn/FileZilla3/trunk")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd $_pkgname
+ svnversion
+}
+
+build() {
+ cd $_pkgname
+ autoreconf -i
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $_pkgname
+ make DESTDIR=$pkgdir install
+}
diff --git a/filezilla-svn.install b/filezilla-svn.install
new file mode 100644
index 000000000000..272ceaacbab4
--- /dev/null
+++ b/filezilla-svn.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -f /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}