summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhayao2021-01-09 18:58:50 +0900
committerhayao2021-01-09 18:58:50 +0900
commitf5eb0fc4ada28d435a9f898c8a690465eed5075b (patch)
tree9b35034cd474ef155128a9479b00f3199262de94
parent68651f433f209a312c0156dface9c21d9c30df1c (diff)
downloadaur-f5eb0fc4ada28d435a9f898c8a690465eed5075b.tar.gz
[update] : Updated 3.52.0.5
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD36
2 files changed, 23 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca45ce03ea79..a852fc0973df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = filezilla-bin
pkgdesc = Free, open source FTP, FTPS and SFTP client (Pre-built binary)
- pkgver = 3.51.0
+ pkgver = 3.52.0.5
pkgrel = 1
url = https://filezilla-project.org
arch = i686
@@ -18,8 +18,11 @@ pkgbase = filezilla-bin
provides = filezilla-git
conflicts = filezilla
conflicts = filezilla-git
- source = FileZilla_3.51.0_x86_64-linux-gnu.tar.bz2::https://download.filezilla-project.org/client/FileZilla_3.51.0_x86_64-linux-gnu.tar.bz2
- sha512sums = acb04d4ad38223712489c805a86827690688f8660759ae3082fdcbbe2d0d91cac268fe727d5c8252e1248b9cb995496b7c269106618eee9dfdf2f3d00afd647d
+ conflicts = libfilezilla
+ source_i686 = FileZilla_3.52.0.5_i686-linux-gnu.tar.bz2::https://download.filezilla-project.org/client/FileZilla_3.52.0.5_i686-linux-gnu.tar.bz2
+ sha512sums_i686 = cda81584a156d306b790c7ad704a4d18df0d4c633f1db488b9b4aad2d1e749a88faf2a28d68637e3ccba07cf785233e7fcf5b339dbebba65be88a195f6ce6370
+ source_x86_64 = FileZilla_3.52.0.5_x86_64-linux-gnu.tar.bz2::https://download.filezilla-project.org/client/FileZilla_3.52.0.5_x86_64-linux-gnu.tar.bz2
+ sha512sums_x86_64 = 0776ca75c84daa4f2e55e43d32b2ca2577e939f146b6057a00011b19c80d650bf3994960e6091be98cb911c5094a750629cbfe5658f0388ab69e7cca98788f5b
pkgname = filezilla-bin
diff --git a/PKGBUILD b/PKGBUILD
index 6e38414b87e8..248fa95ce0d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=filezilla
pkgname="$_pkgname-bin"
-pkgver=3.51.0
+pkgver=3.52.0.5
pkgrel=1
pkgdesc='Free, open source FTP, FTPS and SFTP client (Pre-built binary)'
arch=('i686' 'x86_64')
@@ -11,25 +11,23 @@ license=('GPL')
depends=('pugixml' 'wxgtk3' 'xdg-utils' 'gmp' 'gnutls' 'nettle' 'sqlite')
makedepends=('curl')
provides=("${_pkgname}" "${_pkgname}-git")
-conflicts=("${_pkgname}" "${_pkgname}-git")
-
-machine_arch="$(uname -m)"
-
-source=(
- "FileZilla_${pkgver}_${machine_arch}-linux-gnu.tar.bz2::https://download.filezilla-project.org/client/FileZilla_${pkgver}_${machine_arch}-linux-gnu.tar.bz2"
-)
-
-sha512sums=(
- "$(
- _url="https://download.filezilla-project.org/client/FileZilla_${pkgver}.sha512"
- _sum=$(curl --silent -L "${_url}" | grep "FileZilla_${pkgver}_${machine_arch}-linux-gnu.tar.bz2" | awk '{print $1}')
- if [[ ! "${?}" = 0 ]] || [[ ! -v "_sum" ]]; then
- echo -n "SKIP"
- else
- echo -n "${_sum}"
- fi
+conflicts=("${_pkgname}" "${_pkgname}-git" "libfilezilla")
+machine_arch="${CARCH}"
+
+for _arch in ${arch[@]}; do
+ eval "source_${_arch}=(FileZilla_${pkgver}_${_arch}-linux-gnu.tar.bz2::https://download.filezilla-project.org/client/FileZilla_${pkgver}_${_arch}-linux-gnu.tar.bz2)"
+ eval "sha512sums_${_arch}=(
+ '$(
+ _url="https://download.filezilla-project.org/client/FileZilla_${pkgver}.sha512"
+ _sum=$(curl --silent -L "${_url}" | grep "FileZilla_${pkgver}_${_arch}-linux-gnu.tar.bz2" | awk '{print $1}')
+ if [[ ! "${?}" = 0 ]] || [[ ! -v "_sum" ]]; then
+ echo -n "SKIP"
+ else
+ echo -n "${_sum}"
+ fi
+ )'
)"
-)
+done
package() {
rm -rf "${srcdir}/FileZilla_${pkgver}_${machine_arch}-linux-gnu.tar.bz2"