summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornic962017-02-20 20:50:21 -0600
committernic962017-02-20 20:50:21 -0600
commit629b67a3c7b0dae26729b9fe928d29dfbada2c99 (patch)
tree06db27fbc74b685956e4f7bf5300aac0e56ec10c
downloadaur-629b67a3c7b0dae26729b9fe928d29dfbada2c99.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
-rw-r--r--filmic-blender.desktop87
3 files changed, 133 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..525d0d39916f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = filmic-blender-git
+ pkgdesc = Filmic View and Look Transformations for Blender
+ pkgver = 20170218
+ pkgrel = 1
+ url = https://sobotka.github.io/filmic-blender/
+ arch = any
+ license = GPL3
+ depends = blender
+ provides = filmic-blender
+ source = git+https://github.com/sobotka/filmic-blender.git
+ source = filmic-blender.desktop
+ md5sums = SKIP
+ md5sums = 68d8e7cbb520196b7715cb882f3cffac
+
+pkgname = filmic-blender-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89685fd4c700
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: nic96 <jeromyreimer at gmail dot com>
+
+pkgname=filmic-blender-git
+pkgver=20170218
+blenderver=$(blender -v | grep Blender | grep -o '[0-9]\.[0-9][0-9]')
+pkgrel=1
+pkgdesc="Filmic View and Look Transformations for Blender"
+arch=('any')
+url="https://sobotka.github.io/filmic-blender/"
+license=('GPL3')
+depends=('blender')
+provides=('filmic-blender')
+source=("git+https://github.com/sobotka/filmic-blender.git"
+ "filmic-blender.desktop")
+md5sums=('SKIP' '68d8e7cbb520196b7715cb882f3cffac')
+
+prepare() {
+ cd $srcdir
+ sed -i "s/blenderver/${blenderver}/" filmic-blender.desktop
+}
+
+package() {
+ cd $srcdir
+
+ install -d "$pkgdir/usr/share/blender/$blenderver/datafiles/filmic-blender"
+ cp -r $srcdir/filmic-blender/* "$pkgdir/usr/share/blender/$blenderver/datafiles/filmic-blender"
+
+ # desktop file
+ install -Dm644 filmic-blender.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+}
diff --git a/filmic-blender.desktop b/filmic-blender.desktop
new file mode 100644
index 000000000000..14523c6d3ff7
--- /dev/null
+++ b/filmic-blender.desktop
@@ -0,0 +1,87 @@
+[Desktop Entry]
+Name=Filmic Blender
+GenericName=3D modeler
+GenericName[ar]=3D المنمذج ثلاثي الأبعاد
+GenericName[ca]=Modelador 3D
+GenericName[cs]=3D modelování
+GenericName[da]=3D-modellering
+GenericName[de]=3D-Modellierer
+GenericName[el]=Μοντελοποιητής 3D
+GenericName[es]=Modelador 3D
+GenericName[et]=3D modelleerija
+GenericName[fi]=3D-mallintaja
+GenericName[fr]=Modeleur 3D
+GenericName[gl]=Modelador 3D
+GenericName[hu]=3D modellező
+GenericName[it]=Modellatore 3D
+GenericName[ja]=3D モデラー
+GenericName[lt]=3D modeliavimas
+GenericName[nb]=3D-modellering
+GenericName[nl]=3D-modeller
+GenericName[pl]=Modelowanie 3D
+GenericName[pt_BR]=Modelador 3D
+GenericName[ro]=Arhitect 3D
+GenericName[ru]=Редактор 3D-моделей
+GenericName[tr]=3D modelleyici
+GenericName[uk]=Редактор 3D-моделей
+GenericName[wa]=Modeleu 3D
+GenericName[zh_CN]=3D 建模
+GenericName[zh_TW]=3D 模型
+Comment=3D modeling, animation, rendering and post-production
+Comment[ar]=3D النمذجة، الرسوم المتحركة، والتجسيد، وما بعد الإنتاج
+Comment[ast]=Modeláu 3D, animación, renderizáu y postproducción
+Comment[eu]=3D modelatzea, animazioa, errendatzea eta post-produkzioa
+Comment[be]=Праграма прасторавага мадэлявання, анімацыі, апрацоўкі відэа і давядзення відэапрадукцыі
+Comment[bn]=ত্রিমাত্রিক মডেল, অ্যানিমেশন, রেন্ডারিং এবং পোস্ট-উৎপাদন
+Comment[bs]=3D modeliranje, animacija, obrada i postprodukcija
+Comment[bg]=3D моделиране, анимиране, рендиране и пост-продукция
+Comment[ca]=Modelat 3D, animació, renderització i post-producció
+Comment[ca@valencia]=Modelat 3D, animació, renderització i post-producció
+Comment[crh]=3B modelleme, animasyon, işleme ve son üretim
+Comment[cs]=3D modelování, animace, rederování a postprodukce
+Comment[da]=3D-modellering, animation, rendering og efterbehandling
+Comment[de]=3D-Modellierung, Animation, Rendering und Nachbearbeitung
+Comment[nl]=3d-modelleren, animeren, renderen en post-productie
+Comment[el]=Μοντελοποίηση 3D, κινούμενα σχέδια, αποτύπωση και οργάνωση διαδικασίας μετά-την-παραγωγή
+Comment[eo]=3D-modelado, animacio, renderado kaj postproduktado
+Comment[es]=Modelado 3D, animación, renderizado y post-producción
+Comment[et]=Kolmemõõtmeline modelleerimine, animeerimine, esitlemine ja järeltöötlemine
+Comment[fi]=3D-mallinnus, -animaatiot, -renderöinti ja -tuotanto
+Comment[fr]=Modélisation 3D, animation, rendu et post-production
+Comment[fr_CA]=Modélisation 3D, animation, rendu et post-production
+Comment[gl]=Modelado 3D, animación, renderizado e postprodución
+Comment[hu]=3D modellek és animációk létrehozása és szerkesztése
+Comment[is]=Þrívíddarmódel, hreyfimyndir, myndgerð og frágangur myndskeiða
+Comment[it]=Modellazione 3D, animazione, rendering e post-produzione
+Comment[ja]=3Dモデリング、アニメーション、レンダリング、ポストプロダクションのツール
+Comment[ko]=3D 모델링, 애니메이션, 렌더링과 포스트 프로덕션
+Comment[lt]=3D modeliavimas, animacijų kūrimas, atvaizdavimas ir tobulinimas
+Comment[lv]=3D modelēšana, animācija, renderēšana un pēcapstrāde
+Comment[ms]=Pemodelan, animasi, penerapan dan post-produksi 3D
+Comment[nb]=3D-modellering, animasjon, rendering og postproduksjon
+Comment[oc]=Modelizacion 3D, animacion, rendut e post-produccion
+Comment[pl]=Modelowanie 3D, animacja, renderowanie i postprodukcja
+Comment[pt]=Modelação 3D, animação, renderização e pós-produção
+Comment[pt_BR]=Modelagem 3D, animação, renderização e pós-produção
+Comment[ro]=Modelare, animare, afișare și post-producție 3D
+Comment[ru]=3D-моделирование, анимация, рендеринг и компоновка
+Comment[sl]=3D modeliranje, animacija, izrisovanje in nadaljnje obdelovanje
+Comment[sq]=Animacion i modeleve 3D, rregullim dhe më pas prodhim
+Comment[sr]=3Д моделовање, анимација, исцртавање и постпродукција
+Comment[sv]=3d-modellering, animering, rendering och efterbehandling
+Comment[ta]=முப்பரிமாண ஒப்புருவாக்கம், அசைவூட்டம், காட்சியாக்கம் மற்றும் உருவாக்கத்துக்கு பிந்தைய செயல்பாடுகள்
+Comment[tg]=Моделсозии 3D, аниматсия, пешниҳод ва истеҳсоли баъдӣ
+Comment[tr]=3B modelleme, animasyon, işleme ve son üretim
+Comment[uk]=Програма просторового моделювання, анімації, обробки відео та доведення відеопродуктів
+Comment[vi]=Tạo hình mẫu 3D, hoạt họa, dựng hình và các công việc hậu kỳ
+Comment[wa]=Modelaedje 3D, animåcion, rindou eyet après-produccion
+Comment[zh_HK]=3D 模型、動畫、算圖和後製
+Comment[zh_CN]=3D 建模、动画、渲染和后期制作
+Comment[zh_TW]=3D 模型、動畫、算圖和後製
+Keywords=3d;cg;modeling;animation;painting;sculpting;texturing;video editing;video tracking;rendering;render engine;cycles;game engine;python;
+Exec=env OCIO=/usr/share/blender/blenderver/datafiles/filmic-blender/config.ocio blender %f
+Icon=blender
+Terminal=false
+Type=Application
+Categories=Graphics;3DGraphics;
+MimeType=application/x-blender;