summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordaniel-j2018-03-14 22:24:52 +0100
committerdaniel-j2018-03-14 22:24:52 +0100
commitdf6053b91f314cbda780bbe7148fc38f1fe68ce0 (patch)
treea9e10f04911eadb6045062c7c3cd04b9b3d95156
parent96ffb37abf1b5496df2d52008bcecbc650c3dc47 (diff)
downloadaur-df6053b91f314cbda780bbe7148fc38f1fe68ce0.tar.gz
use yarn, update to v1.7.22
-rw-r--r--.SRCINFO10
-rwxr-xr-xPKGBUILD20
2 files changed, 17 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4065a5722d17..2f6a939c456c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = fimfic2epub
pkgdesc = Tool to generate improved EPUB ebooks from Fimfiction stories
- pkgver = 1.7.16
- pkgrel = 2
+ pkgver = 1.7.22
+ pkgrel = 1
url = https://github.com/daniel-j/fimfic2epub
arch = any
license = MIT
- makedepends = npm
+ makedepends = yarn
depends = nodejs
options = !strip
- source = https://github.com/daniel-j/fimfic2epub/archive/v1.7.16.tar.gz
- sha256sums = d54d1da674f91df54b0aae433cdc4cc4baa3a4fb6dd2d476cf0f4d6be056b1bd
+ source = https://github.com/daniel-j/fimfic2epub/archive/v1.7.22.tar.gz
+ sha256sums = 68a6a5e0955adc065f864eb44992af6983aae30d0a9a797bced63a1bdf2fc9a5
pkgname = fimfic2epub
diff --git a/PKGBUILD b/PKGBUILD
index 63cf7daec55b..b3fbe3fb99f5 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,30 @@
# Maintainer: djazz
pkgname=fimfic2epub
-pkgver=1.7.16
-pkgrel=2
+pkgver=1.7.22
+pkgrel=1
pkgdesc="Tool to generate improved EPUB ebooks from Fimfiction stories"
arch=('any')
url="https://github.com/daniel-j/fimfic2epub"
license=('MIT')
depends=('nodejs')
-makedepends=('npm')
+makedepends=('yarn')
options=(!strip)
source=("https://github.com/daniel-j/fimfic2epub/archive/v${pkgver}.tar.gz")
sha256sums=(
- 'd54d1da674f91df54b0aae433cdc4cc4baa3a4fb6dd2d476cf0f4d6be056b1bd'
+ '68a6a5e0955adc065f864eb44992af6983aae30d0a9a797bced63a1bdf2fc9a5'
)
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- npm install --user root --cache="${srcdir}/npm-cache"
- npm install --user root --cache="${srcdir}/npm-cache" --prefix "${srcdir}" removeNPMAbsolutePaths
- "${srcdir}/node_modules/.bin/removeNPMAbsolutePaths" . 2>&1
- npm run build webpack -- --standalone
+ export YARN_CACHE_FOLDER="${srcdir}/yarn-cache"
+
+ echo "Installing dependencies..."
+ yarn install --non-interactive --no-lockfile --ignore-engines
+
+ echo "Building fimfic2epub..."
+ yarn run build webpack --standalone
+
install -D "bin/fimfic2epub-static" "${pkgdir}/usr/bin/${pkgname}"
install -Dm 644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}