summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-06 11:20:23 +0800
committerzxp198210052024-03-06 11:20:23 +0800
commitd86dd4da36f7f4a1dd4a647b2e7dde80b34e63bf (patch)
treef9f7ac0657b1848286089f1fd8ecd41670a28a1a
parent8518ad20aa6bb83c08d1091af30f87e5e3f790fe (diff)
downloadaur-d86dd4da36f7f4a1dd4a647b2e7dde80b34e63bf.tar.gz
fix errors
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD16
-rw-r--r--final2x.sh3
3 files changed, 21 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 204e2cc7444e..1e61f191ccd1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,24 @@
pkgbase = final2x-bin
pkgdesc = 2^x Image Super-Resolution
pkgver = 1.2.0
- pkgrel = 2
+ pkgrel = 3
url = https://final2x.tohru.top/
arch = x86_64
- license = BSD
+ license = BSD-3-Clause
depends = electron27
depends = python>=3.8
depends = nodejs
+ depends = openssl-1.1
+ depends = libice
+ depends = libbsd
+ depends = libsm
conflicts = final2x
options = !strip
- source = final2x-1.2.0.deb::https://github.com/Tohrusky/Final2x/releases/download/2024-01-02/Final2x-linux-pip-x64-deb.deb
+ source = final2x-1.2.0.deb::https://github.com/Tohrusky/Final2x/releases/download/2024-01-02/Final2x-ubuntu-x64-deb.deb
source = LICENSE-1.2.0::https://raw.githubusercontent.com/Tohrusky/Final2x/2024-01-02/LICENSE
source = final2x.sh
- sha256sums = bc79595c6b0ec89be92aa57165e293c4aa2ed92d862df9d48c2efb2eb770eccf
+ sha256sums = e10fba1653ffc6d294ed845d05ddb8701d28c3a95d3cd65c35b0960af23c6056
sha256sums = 7b4e93ff707625a2632519b35d5891035356f551f18dd18539ad94c72f59286a
- sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
+ sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
pkgname = final2x-bin
diff --git a/PKGBUILD b/PKGBUILD
index 32ec53ffeb45..9c9eab165ba2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,10 @@ _pkgname=Final2x
pkgver=1.2.0
_date=2024-01-02
_electronversion=27
-pkgrel=2
+pkgrel=3
pkgdesc="2^x Image Super-Resolution"
arch=('x86_64')
-license=('BSD')
+license=('BSD-3-Clause')
conflicts=("${pkgname%-bin}")
url="https://final2x.tohru.top/"
_ghurl="https://github.com/Tohrusky/Final2x"
@@ -15,24 +15,28 @@ depends=(
"electron${_electronversion}"
'python>=3.8'
'nodejs'
+ 'openssl-1.1'
+ 'libice'
+ 'libbsd'
+ 'libsm'
)
options=(
'!strip'
)
source=(
- "${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/${_date}/${_pkgname}-linux-pip-x64-deb.deb"
+ "${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/${_date}/${_pkgname}-ubuntu-x64-deb.deb"
"LICENSE-${pkgver}::https://raw.githubusercontent.com/Tohrusky/Final2x/${_date}/LICENSE"
"${pkgname%-bin}.sh"
)
-sha256sums=('bc79595c6b0ec89be92aa57165e293c4aa2ed92d862df9d48c2efb2eb770eccf'
+sha256sums=('e10fba1653ffc6d294ed845d05ddb8701d28c3a95d3cd65c35b0960af23c6056'
'7b4e93ff707625a2632519b35d5891035356f551f18dd18539ad94c72f59286a'
- '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
+ '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- bsdtar -xf "${srcdir}/data.tar.xz"
+ bsdtar -xf "${srcdir}/data."*
sed "s|/opt/${_pkgname}/${pkgname%-bin}|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
diff --git a/final2x.sh b/final2x.sh
index f9ced1432cfc..86cb3dc6a9bf 100644
--- a/final2x.sh
+++ b/final2x.sh
@@ -1,10 +1,11 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then