summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksandar Trifunovic2018-09-28 23:55:16 +0200
committerAleksandar Trifunovic2018-09-28 23:55:16 +0200
commit051c4d15b1efe2610416d6369ad50fb5c16b76db (patch)
treece008ddeee3c6d9d737896059010c7dc9b5f7d62
downloadaur-051c4d15b1efe2610416d6369ad50fb5c16b76db.tar.gz
0.4.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD39
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60e4a64bdb0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = finalcut
+ pkgdesc = A text-based widget toolkit.
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://github.com/gansm/finalcut
+ arch = x86_64
+ license = GPL3
+ depends = gpm
+ source = https://github.com/gansm/finalcut/archive/0.4.0.tar.gz
+ sha256sums = aca3677effd71381af51ac716e17089b3de9429e62973885669e269bd7a85e0a
+
+pkgname = finalcut
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a5e599fd50c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Aleksandar Trifunović <akstrfn at gmail dot com>
+
+pkgname=finalcut
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="A text-based widget toolkit."
+arch=('x86_64')
+url="https://github.com/gansm/finalcut"
+license=('GPL3')
+depends=('gpm')
+makedepends=()
+source=("${url}/archive/$pkgver.tar.gz")
+sha256sums=('aca3677effd71381af51ac716e17089b3de9429e62973885669e269bd7a85e0a')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ # Does not build because of -Werror=stringop-truncation atm
+ sed -i "s/-Werror//" src/Makefile.am
+
+ autoreconf -if
+ ./configure --prefix=/usr
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim: set softtabstop=4 shiftwidth=4 expandtab: