summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbandithedoge2020-09-09 13:37:38 +0200
committerbandithedoge2020-09-09 13:37:38 +0200
commitfd2030afe472aa4acb3d6db946e41655b80d9d81 (patch)
treee0d32cf69d4560d8d69f37c1b82300c49ed31b49
downloadaur-fd2030afe472aa4acb3d6db946e41655b80d9d81.tar.gz
initial push
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4304110ec72
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = finalhe-git
+ pkgdesc = A tool to push h-encore exploit for PS VITA/PS TV automatically
+ pkgver = 1.92.r7.g624b8eb
+ pkgrel = 1
+ url = https://github.com/soarqin/finalhe
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = libxml2
+ depends = libusb
+ depends = zlib
+ depends = qt5-base
+ provides = finalhe
+ conflicts = finalhe
+ source = finalhe-git::git://github.com/soarqin/finalhe.git
+ md5sums = SKIP
+
+pkgname = finalhe-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc07d8e0387e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: MikoĊ‚aj Lercher <bandithedoge@protonmail.com>
+
+_pkgname='finalhe'
+pkgname=${_pkgname}-git
+pkgver=1.92.r7.g624b8eb
+pkgrel=1
+pkgdesc="A tool to push h-encore exploit for PS VITA/PS TV automatically"
+arch=('x86_64')
+url="https://github.com/soarqin/${_pkgname}"
+license=('GPL')
+depends=('libxml2' 'libusb' 'zlib' 'qt5-base')
+makedepends=('git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("$pkgname::git://github.com/soarqin/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed -r 's,^[^0-9]*,,;s,([^-]*-g),r\1,;s,[-_],.,g'
+}
+
+build() {
+ cd "$pkgname"
+ qmake
+ make
+ cd "src"
+ make lcopy
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 src/FinalHE "$pkgdir/usr/bin/finalhe"
+ install -Dm644 ./README.md "$pkgdir/usr/share/doc/$pkgname"
+}