summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Agura2016-07-05 01:00:11 +0300
committerAlexander Agura2016-07-05 01:00:11 +0300
commitd6c3b8a1a10df2ab0257c2a457de10ef98e46055 (patch)
tree5f16d734b603614c4e3121b5434983940043d322
parent014b65090cc760aa451c3efa2c62b2428f03b1e3 (diff)
downloadaur-d6c3b8a1a10df2ab0257c2a457de10ef98e46055.tar.gz
1.1-1
-rw-r--r--PKGBUILD8
-rw-r--r--find-the-command.install16
2 files changed, 14 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f31562e08143..18b2e5502b4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Alexander Agura <agur4ik09@gmail.com>
pkgname=find-the-command
-pkgver=1.0.2
+pkgver=1.1
pkgrel=1
pkgdesc="Interactive command-not-found hook for bash and zsh using the power of pacman"
arch=('any')
@@ -12,9 +12,13 @@ backup=('usr/lib/systemd/system/pacman-files.service'
'usr/lib/systemd/system/pacman-files.timer')
install=find-the-command.install
source=("https://github.com/agur4ik/$pkgname/archive/$pkgver.tar.gz")
-md5sums=(74442eed8f114ffcdad379c26c2555d7)
+md5sums=(360a2ccb5fefe528f19ce90b9c619c66)
package() {
cd "$pkgname-$pkgver"
+ rm .gitignore
+ mkdir -p usr/share/licenses/$pkgname
+ mv LICENSE usr/share/licenses/$pkgname/
+ mv README.md usr/share/doc/$pkgname/
cp -a * $pkgdir/
}
diff --git a/find-the-command.install b/find-the-command.install
index 04feb423bdc1..fb30b1bd9034 100644
--- a/find-the-command.install
+++ b/find-the-command.install
@@ -2,15 +2,15 @@ post_install() {
cat <<EOF
>> To enable command-not-found hook for your shell
>> add any of the following to your .bashrc or .zshrc file
- >> depending on shell you use:
- >> for bash (interactive):
- source /usr/share/doc/find-the-command/ftc-interactive.bash
- >> for non-interactive use:
+ >> depending on the shell you use:
+ >> for bash:
source /usr/share/doc/find-the-command/ftc.bash
- >> for zsh (interactive):
- source /usr/share/doc/find-the-command/ftc-interactive.zsh
- >> non-interactive:
+ >> for zsh:
source /usr/share/doc/find-the-command/ftc.zsh
+ >> You can also append 'su' option to use su instead of sudo
+ >> for root access or 'noprompt' to disable inatallation
+ >> prompt at all. I.e.:
+ source /usr/share/doc/find-the-command/ftc.zsh noprompt
>> It is necessary to create pacman files database, run
sudo pacman -Fy
@@ -30,5 +30,5 @@ pre_remove() {
}
post_remove() {
- printf "\t>> Don't for get to remove hook from your shell rc-file\n"
+ printf "\t>> Don't forget to remove the hook from your shell rc-file\n"
}