summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Kasemir2022-08-04 23:26:24 -0600
committerPaul Kasemir2022-08-04 23:26:24 -0600
commit75964cdb7534d433df750e6efffd162c4a9628b0 (patch)
tree9f99b093995b4c3e57962837c3a3acfa6a804db2
parent74222edd14c37980aec5cb1c8c093d353edd3575 (diff)
downloadaur-75964cdb7534d433df750e6efffd162c4a9628b0.tar.gz
Stop installing the removed systemd timer
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--find-the-command.install12
3 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e03015835c6f..7e4338c414bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = find-the-command-git
pkgdesc = Advanced command-not-found hook for bash, fish and zsh using the power of pacman
- pkgver = 2.0.r0.g05157f6
+ pkgver = 2.0.r2.gfecba1a
pkgrel = 1
url = https://github.com/pkasemir/find-the-command
install = find-the-command.install
arch = any
- license = WTFPL
+ license = custom:WTFPL
makedepends = git
depends = pacman
- depends = systemd
optdepends = fzf: highly recommended for package selection and previews
+ optdepends = pacman-contrib: for weekly pacman-filesdb-refresh.timer
optdepends = pkgfile: provides faster searches than pacman
+ optdepends = sudo: helpful for privilege elevation
provides = find-the-command
conflicts = find-the-command
+ options = docs
source = git+https://github.com/pkasemir/find-the-command.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 687ae7092871..3cb50e8b5b5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,22 @@
# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Paul Kasemir <paul.kasemir@gmail.com>
pkgname=find-the-command-git
-pkgver=2.0.r0.g05157f6
+pkgver=2.0.r2.gfecba1a
pkgrel=1
pkgdesc="Advanced command-not-found hook for bash, fish and zsh using the power of pacman"
arch=('any')
url="https://github.com/pkasemir/find-the-command"
-license=('WTFPL')
-depends=('pacman' 'systemd')
+license=('custom:WTFPL')
+depends=('pacman')
optdepends=('fzf: highly recommended for package selection and previews'
- 'pkgfile: provides faster searches than pacman')
+ 'pacman-contrib: for weekly pacman-filesdb-refresh.timer'
+ 'pkgfile: provides faster searches than pacman'
+ 'sudo: helpful for privilege elevation')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
install="${pkgname%-git}.install"
+options=('docs')
source=('git+https://github.com/pkasemir/find-the-command.git')
sha256sums=('SKIP')
@@ -25,8 +28,6 @@ pkgver() {
package() {
cd "$srcdir/${pkgname%-git}"
- install -Dm644 usr/lib/systemd/system/pacman-files{.service,.timer} -t \
- "$pkgdir/usr/lib/systemd/system"
install -Dm644 README.md usr/share/doc/"${pkgname%-git}"/ftc.* -t \
"$pkgdir/usr/share/doc/${pkgname%-git}"
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
diff --git a/find-the-command.install b/find-the-command.install
index 56f59d793686..e10f83dec698 100644
--- a/find-the-command.install
+++ b/find-the-command.install
@@ -19,9 +19,10 @@ post_install() {
>> Example:
source /usr/share/doc/find-the-command/ftc.zsh noprompt quiet
- >> You may also want to enable timer for regular
- >> pacman or pkgile files database update:
- # systemctl enable pacman-files.timer
+ >> You may also want to enable timer for regular files database updates:
+ >> When using pacman (and have package "pacman-contrib" installed):
+ # systemctl enable pacman-filesdb-refresh.timer
+ >> Or when using pkgfile
# systemctl enable pkgfile-update.timer
EOF
}
@@ -30,11 +31,6 @@ post_upgrade() {
post_install
}
-pre_remove() {
- printf "\t>> Disabling pacman files systemd timer\n"
- systemctl disable pacman-files.timer
-}
-
post_remove() {
printf "\t>> Don't forget to remove the hook from your shell rc-file\n"
}