summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Franco2018-04-04 06:53:23 -0400
committerJesus Franco2018-04-04 06:53:23 -0400
commit1e102ab4cc757bec48419aad3da905848057d37a (patch)
treed7809481adad27aa905fa80233ccb02b6b2c16ac
downloadaur-1e102ab4cc757bec48419aad3da905848057d37a.tar.gz
initial release
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD32
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1744096abd9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = findfileconflicts-git
+ pkgdesc = Helps to find file names which could have conflicts on Windows
+ pkgver = 2018.04.04
+ pkgrel = 1
+ url = https://github.com/artemanufrij/findfileconflicts
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = desktop-file-utils
+ makedepends = hicolor-icon-theme
+ makedepends = intltool
+ makedepends = yelp-tools
+ makedepends = gnome-common
+ makedepends = gobject-introspection
+ makedepends = meson
+ makedepends = ninja
+ depends = glib2
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = vala
+ depends = granite
+ depends = libpurple
+ depends = gtksourceview3
+ depends = libdbusmenu-gtk3
+ optdepends = elementary-icon-theme
+ provides = findfileconflicts
+ conflicts = findfileconflicts
+ conflicts = findfileconflicts-bzr
+ options = !libtool
+ source = git+https://github.com/artemanufrij/findfileconflicts.git
+ md5sums = SKIP
+
+pkgname = findfileconflicts-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b230bbb34d6e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jesus Franco <jesusfranco at gmail dot com>
+
+_pkgname="findfileconflicts"
+pkgname="${_pkgname}-git"
+_gitname=findfileconflicts
+pkgver=2018.04.04
+pkgrel=1
+pkgdesc="Helps to find file names which could have conflicts on Windows"
+arch=('i686' 'x86_64')
+url="https://github.com/artemanufrij/${_pkgname}"
+license=('GPL3')
+
+depends=('glib2' 'gtk3' 'hicolor-icon-theme' 'vala' 'granite' 'libpurple' 'gtksourceview3' 'libdbusmenu-gtk3')
+optdepends=('elementary-icon-theme')
+makedepends=('git' 'desktop-file-utils' 'hicolor-icon-theme' 'intltool' 'yelp-tools' 'gnome-common' 'gobject-introspection' 'meson' 'ninja')
+options=('!libtool')
+conflicts=('findfileconflicts' 'findfileconflicts-bzr')
+provides=('findfileconflicts')
+source=("git+https://github.com/artemanufrij/findfileconflicts.git")
+md5sums=('SKIP')
+
+build() {
+ cd "${_pkgname}"
+ meson build --prefix=/usr
+ cd build
+ ninja
+}
+
+package() {
+ cd "${_gitname}/build"
+ DESTDIR="${pkgdir}" ninja install
+}