summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2013-08-23 16:58:29 +0400
committerAnton Leontiev2015-02-15 07:48:01 +0300
commit1f79de448707d50b6e7e6fba6fd48e44fceb6936 (patch)
treefd1bb9b440a8ccbddc89721dc871868d4ef338b5
downloadaur-1f79de448707d50b6e7e6fba6fd48e44fceb6936.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD29
-rw-r--r--findimagedupes-2.18.patch36
4 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..138cd0c03804
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = findimagedupes
+ pkgdesc = Tool to find visually similar or duplicate images
+ pkgver = 2.18
+ pkgrel = 2
+ url = http://www.jhnc.org/findimagedupes/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = perl
+ makedepends = sed
+ depends = perl
+ depends = perl-file-mimeinfo
+ depends = perl-inline
+ depends = graphicsmagick
+ options = zipman
+ source = http://www.jhnc.org/findimagedupes/findimagedupes-2.18.tar.gz
+ source = findimagedupes-2.18.patch
+ md5sums = 5c353c6e4611e194114d4192c32c6adb
+ md5sums = 7a75e6e1f0520bd1d02c3862417f3829
+
+pkgname = findimagedupes
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a30efadb725
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Stefano Tortarolo <stefano@inventati.org>
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+pkgname=findimagedupes
+pkgver=2.18
+pkgrel=2
+pkgdesc="Tool to find visually similar or duplicate images"
+arch=('i686' 'x86_64')
+url="http://www.jhnc.org/findimagedupes/"
+license=('GPL3')
+depends=('perl' 'perl-file-mimeinfo' 'perl-inline' 'graphicsmagick')
+makedepends=('perl' 'sed')
+source=(http://www.jhnc.org/$pkgname/$pkgname-$pkgver.tar.gz
+ findimagedupes-2.18.patch)
+md5sums=('5c353c6e4611e194114d4192c32c6adb'
+ '7a75e6e1f0520bd1d02c3862417f3829')
+options=('zipman')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ sed -i -e "s:DIRECTORY => '/usr/local/lib/$pkgname':DIRECTORY => '/tmp':" $pkgname
+ patch -i $srcdir/findimagedupes-2.18.patch -p0
+ pod2man findimagedupes > findimagedupes.1
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ install -D -m 755 findimagedupes $pkgdir/usr/bin/findimagedupes
+ install -D -m 644 findimagedupes.1 $pkgdir/usr/share/man/man1/findimagedupes.1
+}
diff --git a/findimagedupes-2.18.patch b/findimagedupes-2.18.patch
new file mode 100644
index 000000000000..5d4af864e9e8
--- /dev/null
+++ b/findimagedupes-2.18.patch
@@ -0,0 +1,36 @@
+--- findimagedupes 2013-07-31 17:29:22.616148571 +0000
++++ findimagedupes.new 2013-07-31 18:16:43.073637364 +0000
+@@ -444,7 +444,7 @@
+
+ sub try {
+ my ($err) = @_;
+- if ($err and $err !~ /Warning (315|330):/) {
++ if ($err ne '' and $err !~ /Warning (315|330):/) {
+ die("imagemagick problem: $err\n");
+ }
+ }
+@@ -882,20 +882,20 @@
+
+ =over 4
+
+-=item 0
++=item S<0>
+
+ Success.
+
+-=item 1
++=item S<1>
+
+ Usage information was requested (B<--help> or B<--man>), or there
+ were warnings.
+
+-=item 2
++=item S<2>
+
+ Invalid options or arguments were provided.
+
+-=item 3
++=item S<3>
+
+ Runtime error.
+