summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Macleod2022-03-17 22:02:50 +0000
committerAlex Macleod2022-03-17 22:02:50 +0000
commitd75b9f6480f08cc3b6a18dcd1f50378d565f96a1 (patch)
tree47462eb1e89303577c6c59e52b71eec341a7a642
downloadaur-findpkg.tar.gz
v1.0.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cee06b4a870a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = findpkg
+ pkgdesc = A fast command not found hook
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/Alexendoo/findpkg
+ arch = any
+ license = MIT
+ makedepends = cargo
+ depends = pacman
+ options = emptydirs
+ source = findpkg-1.0.0.tar.gz::https://github.com/Alexendoo/findpkg/archive/v1.0.0.tar.gz
+ sha256sums = 0418c327b8211077b5fe9308bb434faa5a81d8f2f8a64032626f7404d5f310b3
+
+pkgname = findpkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6453743516e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Alex Macleod <alex@macleod.io>
+pkgname=findpkg
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A fast command not found hook"
+arch=(any)
+url="https://github.com/Alexendoo/findpkg"
+license=(MIT)
+depends=(pacman)
+makedepends=(cargo)
+options=(emptydirs)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Alexendoo/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('0418c327b8211077b5fe9308bb434faa5a81d8f2f8a64032626f7404d5f310b3')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release --locked --target-dir target
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 target/release/findpkg "$pkgdir/usr/bin/findpkg"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/findpkg/LICENSE"
+ mkdir -pm755 "$pkgdir/var/lib/findpkg/"
+}