summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Brubeck Unhammer2015-07-14 10:23:49 +0200
committerKevin Brubeck Unhammer2015-07-14 10:23:49 +0200
commit95116445f65d5fcbbccf039978d4fcc10ff1e399 (patch)
tree38c8e65860cf6c3887d6e98197d5aea4c90aa0d6
downloadaur-95116445f65d5fcbbccf039978d4fcc10ff1e399.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d468772642f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = finfaktura
+ pkgdesc = Fryktelig Fin Faktura is an accountancy/billing program for Norwegian businesses. Bills are created as PDF or F60 forms.
+ pkgver = 2.0.6
+ pkgrel = 2
+ url = https://code.google.com/p/finfaktura/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = python2>=2.5.0
+ depends = python-reportlab
+ depends = python2-pyqt
+ source = https://finfaktura.googlecode.com/files/finfaktura-2.0.6.zip
+ md5sums = bc861605f448d5d962bd36ae36a8f5db
+
+pkgname = finfaktura
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d847b34f5d5b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Kevin Brubeck Unhammer <unhammer@gmail.com>
+# Maintainer: Kevin Brubeck Unhammer <unhammer@gmail.com>
+pkgname=finfaktura
+pkgver=2.0.6
+pkgrel=2
+pkgdesc="Fryktelig Fin Faktura is an accountancy/billing program for Norwegian businesses. Bills are created as PDF or F60 forms."
+url="https://code.google.com/p/$pkgname/"
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=('python2>=2.5.0' 'python-reportlab' 'python2-pyqt')
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+install=
+source=("https://finfaktura.googlecode.com/files/$pkgname-$pkgver.zip")
+md5sums=('bc861605f448d5d962bd36ae36a8f5db')
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+
+ # From http://allanmcrae.com/2010/10/big-python-transition-in-arch-linux/
+ sed -i -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
+ -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
+ $(find . -name '*.py')
+
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+
+ mv $pkgdir/usr/bin/faktura.py $pkgdir/usr/bin/finfaktura
+}