summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAliaksandr Stelmachonak a.k.a. ava1ar2019-10-26 02:31:42 -0400
committerAliaksandr Stelmachonak a.k.a. ava1ar2019-10-26 02:31:42 -0400
commitd1b8c41059b4d05c47e91d106177bbcad844137f (patch)
tree26e93e6fc6fa553193d537dd76d84ec656f97aa4
downloadaur-d1b8c41059b4d05c47e91d106177bbcad844137f.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c50b6f0307e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = fing
+ pkgdesc = The ultimate tool for network discovery and scanning
+ pkgver = 5.4.0
+ pkgrel = 1
+ url = https://www.fing.com/images/uploads/general/Fing_CLI_User_Guide_1.2.pdf
+ arch = x86_64
+ license = custom:FING EXECUTABLE LICENSE
+ depends = boost-libs
+ depends = openssl
+ depends = zlib
+ depends = icu55
+ options = !strip
+ source = https://www.fing.com/images/uploads/general/CLI_Linux_others_5.4.0.zip
+ sha1sums = e66136543e7c5169d9a17b88ad836b2a32754ddc
+
+pkgname = fing
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6bc090906bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=fing
+pkgver=5.4.0
+pkgrel=1
+pkgdesc='The ultimate tool for network discovery and scanning'
+arch=('x86_64')
+url='https://www.fing.com/images/uploads/general/Fing_CLI_User_Guide_1.2.pdf'
+license=('custom:FING EXECUTABLE LICENSE')
+depends=('boost-libs' 'openssl' 'zlib' 'icu55')
+options=(!strip)
+source=("https://www.fing.com/images/uploads/general/CLI_Linux_others_${pkgver}.zip")
+sha1sums=('e66136543e7c5169d9a17b88ad836b2a32754ddc')
+
+prepare() {
+ tar -zxvf ${pkgname}-${pkgver}-amd64.tar.gz
+}
+
+package() {
+ cd "${srcdir}"/${pkgname}-${pkgver}-amd64
+ cp -r usr $pkgdir/
+ install -dm755 "${pkgdir}"/etc/${pkgname}
+ install -Dm644 ./usr/local/share/${pkgname}/template/conf/*.properties "${pkgdir}"/etc/${pkgname}/
+ # license
+ install -dm755 "${pkgdir}"/usr/local/share/licenses/${pkgname}
+ ln -s /usr/local/share/${pkgname}/doc/license.txt "${pkgdir}"/usr/local/share/licenses/${pkgname}/license
+ # cleanup
+ rm -rf "${pkgdir}"/usr/local/lib/fing/init.d
+ rm -rf "${pkgdir}"/usr/local/lib/fing/upstart
+ rm -f "${pkgdir}"/usr/bin/fing-uninstall.sh
+}