summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosh Marshall2018-04-04 13:40:05 -0400
committerJosh Marshall2018-04-04 13:40:05 -0400
commit05730e04f606ed06dd3ff90a84c57724eefaad37 (patch)
treeda42b09539fc97805a55e6751f6a1b7bcaa58110
downloadaur-05730e04f606ed06dd3ff90a84c57724eefaad37.tar.gz
First (and likely only) commit for fingerPRINTScan. This tool is used by interproscan, but is not supported anywhere.
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
-rw-r--r--fingerprintscan.tgzbin0 -> 133128 bytes
4 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88fb88b151fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = fingerprintscan
+ pkgdesc = Search against FingerPRINTScan with a protein query sequence to identify the closest matching PRINTS sequence motif fingerprints in a protein sequence.
+ pkgver = 3.5.96
+ pkgrel = 1
+ url = http://130.88.97.239/PRINTS/index.php
+ arch = x86_64
+ license = LGPL
+ makedepends = gcc-libs
+ depends = gcc-libs
+ source = fingerprintscan.tgz
+ md5sums = SKIP
+
+pkgname = fingerprintscan
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1129392dfea3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+fingerprintscan/
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4125b9c18a74
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Josh Marshall <jrmarsha@mtu.edu>
+
+pkgname=fingerprintscan
+pkgver='3.5.96'
+pkgrel=1
+pkgdesc='Search against FingerPRINTScan with a protein query sequence to identify the closest matching PRINTS sequence motif fingerprints in a protein sequence.'
+arch=('x86_64')
+license=('LGPL')
+url='http://130.88.97.239/PRINTS/index.php'
+depends=('gcc-libs')
+makedepends=('gcc-libs')
+provides=()
+source=(
+ fingerprintscan.tgz
+)
+md5sums=(
+'SKIP'
+)
+
+
+build() {
+ cd "$pkgname"
+
+ sed 's/shuffle/ShuffleFlag/g' FingerPrint.cc > FingerPrint.cc.tmp
+ mv FingerPrint.cc.tmp FingerPrint.cc
+ ./configure --exec-prefix=/usr --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/fingerprintscan.tgz b/fingerprintscan.tgz
new file mode 100644
index 000000000000..494b68508d09
--- /dev/null
+++ b/fingerprintscan.tgz
Binary files differ