summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2023-11-16 17:43:48 +0100
committerbegin-theadventure2023-11-16 17:43:48 +0100
commit29da107eb1f6f5a14e672f1717174c5bf7d60453 (patch)
tree2aff0879614eec9717b1bcca91bffb5ed00049f5
downloadaur-29da107eb1f6f5a14e672f1717174c5bf7d60453.tar.gz
5.1.2
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e4919d41767
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = fingrom-bin
+ pkgdesc = Platform-agnostic financial accounting application (binary release)
+ pkgver = 5.1.2
+ pkgrel = 1
+ url = https://github.com/lyskouski/app-finance
+ arch = x86_64
+ license = CCPL:by-nc-nd4
+ depends = gtk3
+ depends = mesa
+ provides = fingrom
+ conflicts = fingrom
+ source = fingrom-5.1.2.tar.gz::https://github.com/lyskouski/app-finance/releases/download/v5.1.2/fingrom_Linux.tar.gz
+ sha256sums = 871de8f7272b91b9bc351c6efaea41b4aa6bf5573a63b25934811d3af1671be5
+
+pkgname = fingrom-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32feb24e8768
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
+
+pkgname=fingrom-bin
+pkgver=5.1.2
+pkgrel=1
+pkgdesc="Platform-agnostic financial accounting application (binary release)"
+url="https://github.com/lyskouski/app-finance"
+arch=('x86_64')
+license=('CCPL:by-nc-nd4')
+depends=('gtk3' 'mesa')
+conflicts=("fingrom")
+provides=("fingrom")
+source=("fingrom-$pkgver.tar.gz::$url/releases/download/v$pkgver/fingrom_Linux.tar.gz")
+sha256sums=('871de8f7272b91b9bc351c6efaea41b4aa6bf5573a63b25934811d3af1671be5')
+
+package() {
+ mkdir -p "$pkgdir/opt/fingrom" "$pkgdir/usr/bin"
+ mv data lib fingrom "$pkgdir/opt/fingrom"
+ ln -s /opt/fingrom/fingrom -t "$pkgdir/usr/bin"
+ install -Dm644 com.tercad.fingrom.desktop -t "$pkgdir/usr/share/applications"
+ install -Dm644 com.tercad.fingrom.svg -t "$pkgdir/usr/share/icons/hicolor/scalable/apps"
+}