summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShutSentry2022-12-05 11:52:42 -0500
committerShutSentry2022-12-05 11:52:42 -0500
commit4f3fae119a8f94f18d9a53b8d1276c9ad5360f48 (patch)
tree763d4e753cb5a98d2cb29fe54ac1c5389664769c
parent1091c376839e4c6e1d5268fc4a38d901bae2eb4f (diff)
downloadaur-4f3fae119a8f94f18d9a53b8d1276c9ad5360f48.tar.gz
Update files
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8467c7f62b5f..88d85bd05e02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = finitodo
- pkgdesc = Finitodo is a simple yet versatile graphical task / todo list manager for Linux.
+ pkgdesc = "Finitodo is a graphical task/todo list manager for Linux that aims to be highly versatile yet not overly complicated. It has robust functionality in areas like reccurence/sorting/filtering but doesn't require digging through lots of menu screens to use."
pkgver = 2.0
- pkgrel = 2
- url = git://gitlab.com/finitodo/finitodo.git
+ pkgrel = 3
+ url = https://gitlab.com/finitodo/finitodo
arch = x86_64
license = GPL
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index 08538c82a9b8..1969951e97b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Your Name <finitodoer@bureau.eu.org>
pkgname=finitodo
pkgver=2.0
-pkgrel=2
-pkgdesc="Finitodo is a simple yet versatile graphical task / todo list manager for Linux."
+pkgrel=3
+pkgdesc="Finitodo is a graphical task/todo list manager for Linux that aims to be highly versatile yet not overly complicated. It has robust functionality in areas like reccurence/sorting/filtering but doesn't require digging through lots of menu screens to use."
arch=(x86_64)
-url="git://gitlab.com/finitodo/finitodo.git"
+url="https://gitlab.com/finitodo/finitodo"
license=('GPL')
depends=(gtk3)
makedepends=(git make)
@@ -19,6 +19,8 @@ build() {
}
package() {
- mkdir -p ${pkgdir}/usr/bin
- install -m 755 finitodo/finitodo ${pkgdir}/usr/bin
+ mkdir -p "${pkgdir}/usr/bin"
+ mkdir -p "${pkgdir}/usr/share/applications"
+ install -m 755 finitodo/finitodo "${pkgdir}/usr/bin"
+ install finitodo/Bin/finitodo.desktop "${pkgdir}/usr/share/applications"
}