summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Vogt2016-02-19 13:40:48 +0100
committerDavid Vogt2016-02-19 13:40:48 +0100
commit5b9a1da8fa070c7893cf250938fa23f31cc2e042 (patch)
tree92ff39d05bacb100eda7ea8306279f048e992406
downloadaur-5b9a1da8fa070c7893cf250938fa23f31cc2e042.tar.gz
Finja, stable version: initial package build
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02688eac4882
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = finja
+ pkgdesc = Index and find your stuff
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://github.com/adfinis-sygroup/finja
+ arch = any
+ license = AGPL3
+ depends = python
+ depends = python-six
+ depends = python-binaryornot
+ provides = finja
+ conflicts = finja-git
+ source = https://pypi.python.org/packages/source/f/finja/finja-1.0.tar.gz
+ source = LICENSE::https://www.gnu.org/licenses/agpl.txt
+ sha256sums = 3795d64d6e3905f33aff28b659010b03f78f4d25188871966ddcc68b3d871548
+ sha256sums = 57c8ff33c9c0cfc3ef00e650a1cc910d7ee479a8bc509f6c9209a7c2a11399d6
+
+pkgname = finja
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..75359a55eab2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+fahrplan-*.tar.gz
+fahrplan-*.tar.xz
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9772ddc0c71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: David Vogt <dave at winged dot ch>
+# This PKGBUILD is maintained at https://github.com/winged/aur-packages
+
+pkgname=finja
+pkgver=1.0
+pkgrel=1
+pkgdesc="Index and find your stuff"
+arch=('any')
+license=('AGPL')
+url='http://github.com/adfinis-sygroup/finja'
+depends=('python' 'python-six' 'python-binaryornot')
+makedepends=()
+provides=('finja')
+conflicts=('finja-git')
+license=('AGPL3')
+arch=('any')
+source=(
+ "https://pypi.python.org/packages/source/f/finja/finja-${pkgver}.tar.gz"
+ "LICENSE::https://www.gnu.org/licenses/agpl.txt"
+)
+sha256sums=(
+ '3795d64d6e3905f33aff28b659010b03f78f4d25188871966ddcc68b3d871548'
+ '57c8ff33c9c0cfc3ef00e650a1cc910d7ee479a8bc509f6c9209a7c2a11399d6'
+)
+
+if [ -n "$VIRTUAL_ENV" ]; then
+ echo "Warning: You're building within a virtualenv. Use"
+ echo "a shell without virtualenv to build this package!"
+ exit 1
+fi
+
+
+build() {
+ cd $srcdir/finja-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/finja-${pkgver}
+ python setup.py install --root="$pkgdir" --optimize=1
+}