summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJared J2025-01-09 13:49:18 +1100
committerJared J2025-01-09 13:49:18 +1100
commita9a2abd358ff567c0a83fae8f3b557749990ba55 (patch)
tree6b6769c4a28e0f7cf5429cdfac7320037b7e4e1d
parentbd1c03173257b2eb193f18a5273170abd84f0be9 (diff)
downloadaur-a9a2abd358ff567c0a83fae8f3b557749990ba55.tar.gz
Remove pip step, add dependency python-pyan3
-rw-r--r--PKGBUILD3
1 files changed, 1 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d97adc7d3eb4..726109e7347b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ arch=('any')
url="https://github.com/louwrentius/fio-plot/"
license=("BSD")
makedepends=("python-setuptools")
-depends=("python" "python-numpy" "python-matplotlib" "python-pillow" "python-pyparsing")
+depends=("python" "python-numpy" "python-matplotlib" "python-pillow" "python-pyparsing" "python-pyan3")
provides=('fio-plot' 'bench-fio')
source=("${pkgname}-${pkgver}-${pkgrel}.tar.gz::https://github.com/louwrentius/fio-plot/archive/v.${pkgver}.tar.gz")
@@ -18,7 +18,6 @@ b2sums=('37d7a8b05f1caa0e004c04e0f9f22d5248ee5d7f2cb8d76347fe985e0d285e3b63b48ba
package() {
cd "fio-plot-v.${pkgver}"
- python -m pip install -r requirements.txt
python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"