summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2021-04-07 18:26:15 +0800
committertaotieren2021-04-07 18:26:15 +0800
commit8a8020b13bd211c667f7bf75e2a64329e6c61100 (patch)
tree93d855e080a35284d67f42a4193451d70849b1e7
downloadaur-8a8020b13bd211c667f7bf75e2a64329e6c61100.tar.gz
Update fireTools v1.0.1.5
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD22
-rw-r--r--fire-tool.install8
4 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05fb1d015c98
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fire-tool
+ pkgdesc = Embedfire Tool support Serial communication, TCP/UDP communication, camera and PID debuggingVisit https://www.embedfire.com for more information.
+ pkgver = 1.0.1.5
+ pkgrel = 1
+ url = https://www.embedfire.com
+ install = fire-tool.install
+ arch = x86_64
+ groups =
+ license = MIT
+ options = !strip
+ options = !emptydirs
+ source_x86_64 = https://cloud.embedfire.com/software/FireTools/fireTools.deb
+ sha512sums_x86_64 = b6ea80999c5f440aa7b080b4fb535d446a1150f7fd538658921a2112e1d3e4a5ccb363dc4e20ca58ceb6784db337add10312f217b177ada93a383948e6b232a6
+
+pkgname = fire-tool
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a72519b3a6e5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+src
+pkg
+*.deb
+*.rpm
+*.zip
+*.pkg.tar.xz
+*.pkg.tar.zst
+*.log
+*.png
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a161aa19fe3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Generated by debtap
+# Maintainer: taotieren <admin@taotieren.com>
+
+pkgname=fire-tool
+pkgver=1.0.1.5
+pkgrel=1
+pkgdesc="Embedfire Tool support Serial communication, TCP/UDP communication, camera and PID debuggingVisit https://www.embedfire.com for more information."
+arch=('x86_64')
+url="https://www.embedfire.com"
+license=('MIT')
+groups=('')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source_x86_64=("https://cloud.embedfire.com/software/FireTools/fireTools.deb")
+sha512sums_x86_64=('b6ea80999c5f440aa7b080b4fb535d446a1150f7fd538658921a2112e1d3e4a5ccb363dc4e20ca58ceb6784db337add10312f217b177ada93a383948e6b232a6')
+
+package(){
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+
+}
diff --git a/fire-tool.install b/fire-tool.install
new file mode 100644
index 000000000000..409193ccc6d1
--- /dev/null
+++ b/fire-tool.install
@@ -0,0 +1,8 @@
+post_install() {
+ sudo mv /opt/fireTools/fireTools.desktop /usr/share/applications
+ chmod +x /usr/share/applications/fireTools.desktop
+}
+
+post_upgrade() {
+ post_install
+}