summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Mischka2016-10-23 21:49:57 -0500
committerJacob Mischka2016-10-23 21:49:57 -0500
commita8096f5192682285e224e59222cf621afe97518e (patch)
treea26a554ac06942ab650cfff0230ccc9c4949312a
parent242000a8ad1f1acf1916c5d7d2ef316a15c0a3d7 (diff)
downloadaur-a8096f5192682285e224e59222cf621afe97518e.tar.gz
Add .desktop launcher
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD13
-rw-r--r--firebase-admin.desktop8
-rw-r--r--logo.svg26
4 files changed, 48 insertions, 5 deletions
diff --git a/.gitignore b/.gitignore
index 018a3de08144..4d47fd464ce5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,6 @@
*
-!PKGBUILD
-!.SRCINFO
!.gitignore
+!.SRCINFO
+!PKGBUILD
+!firebase-admin.desktop
+!logo.svg
diff --git a/PKGBUILD b/PKGBUILD
index 1697d8293d2d..fd6fb198e133 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,25 @@
pkgname=firebase-admin
_foldername='Firebase Admin'
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='Firebase Management Cross Platform Application.'
url='https://firebaseadmin.com/'
license=('GPL3')
-source=('https://firebaseadmin.com/download.php?file=1.0.0/firebase-admin-linux-1.0.0.zip')
+source=('https://firebaseadmin.com/download.php?file=1.0.0/firebase-admin-linux-1.0.0.zip'
+ 'firebase-admin.desktop'
+ 'logo.svg')
arch=('any')
-md5sums=('9e28e19fe8cdbf5d3f513067eea0f9f4')
+md5sums=('9e28e19fe8cdbf5d3f513067eea0f9f4'
+ 'c9d43aeed4b00d02cb0987fbc408f056'
+ 'b995da0abde8e7766edb76cbc82578c5')
package(){
+ mv logo.svg "$_foldername"
mv "$_foldername/$_foldername" "$_foldername/$pkgname"
install -dm755 "$pkgdir/opt/"
cp -a --reflink=auto "$_foldername" "$pkgdir/opt/$pkgname/"
install -dm755 "$pkgdir/usr/bin"
ln -s "/opt/$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -dm755 "$pkgdir/usr/share/applications"
+ install -Dm755 "$pkgname".desktop "$pkgdir/usr/share/applications/"
}
diff --git a/firebase-admin.desktop b/firebase-admin.desktop
new file mode 100644
index 000000000000..f2458a337daa
--- /dev/null
+++ b/firebase-admin.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Firebase Admin
+Comment=Firebase Management Cross Platform Application.
+Icon=/opt/firebase-admin/logo.svg
+Terminal=false
+Exec=firebase-admin
diff --git a/logo.svg b/logo.svg
new file mode 100644
index 000000000000..b9a2ba0a0951
--- /dev/null
+++ b/logo.svg
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<svg width="210px" height="210px" viewBox="0 0 210 210" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
+ <!-- Generator: Sketch 39.1 (31720) - http://www.bohemiancoding.com/sketch -->
+ <title>logo</title>
+ <desc>Created with Sketch.</desc>
+ <defs>
+ <rect id="path-1" x="0" y="0" width="210" height="210" rx="8"></rect>
+ </defs>
+ <g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
+ <g id="Group-2">
+ <g id="Group">
+ <mask id="mask-2" fill="white">
+ <use xlink:href="#path-1"></use>
+ </mask>
+ <use id="Mask" fill="#FCCA3F" xlink:href="#path-1"></use>
+ <g id="Group-2" mask="url(#mask-2)">
+ <g transform="translate(-16.000000, -7.000000)" id="Path-2">
+ <polygon fill="#F6820C" points="0.795356858 174.064509 168.104776 0.420420321 0.795356858 0.420420321"></polygon>
+ <polygon fill="#FFA712" points="0.795356858 186.962931 99.5703736 0.420420321 0.795356858 0.420420321"></polygon>
+ </g>
+ </g>
+ </g>
+ <path d="M93.24,172.96 L102.48,172.96 L102.48,121.12 L116.16,121.12 L116.16,113.56 L102.48,113.56 L102.48,105.52 C102.48,97.24 106.44,93.88 113.52,93.88 C117.6,93.88 120.12,94.36 121.92,94.72 L121.92,88.24 C119.76,87.16 116.52,86.2 111.84,86.2 C101.04,86.2 93.24,91.84 93.24,104.92 L93.24,113.56 L84.48,113.56 L84.48,121.12 L93.24,121.12 L93.24,172.96 Z M143.04,174.04 C151.08,174.04 156.12,171.16 158.88,167.8 L159.48,167.8 L160.44,172.96 L167.88,172.96 L167.88,129.88 C167.88,117.76 160.56,112.36 147.48,112.36 C140.64,112.36 134.88,113.44 129.72,115.6 L129.72,122.2 C133.44,121.12 138.12,120.28 143.88,120.28 C154.56,120.28 158.64,122.68 158.64,131.92 L158.64,138.16 L142.56,140.08 C131.16,141.4 124.44,146.92 124.44,157.36 C124.44,168.52 132.24,174.04 143.04,174.04 L143.04,174.04 Z M145.32,166.84 C138.48,166.84 134.04,163.6 134.04,157.12 C134.04,150.28 137.64,147.28 144.96,146.56 L158.64,145 L158.64,162.52 C156.12,165.04 150.84,166.84 145.32,166.84 L145.32,166.84 Z" id="fa" fill="#FFFFFF"></path>
+ </g>
+ </g>
+</svg>