summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorosvein2017-02-18 19:18:00 +0100
committerosvein2017-02-18 19:18:00 +0100
commit04af3a15e3bf6aff8296828d005f636d5e6314e3 (patch)
tree624a82c4f87d630938eceeed244fc82d97952cf8
parent98dad7d8d5f62a86cb100e431440201daa2e622c (diff)
downloadaur-04af3a15e3bf6aff8296828d005f636d5e6314e3.tar.gz
Update to Firebird v1.2
Use git to get sources, as GitHub release archive didn't include submodules
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 24 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8a9d439958f..2414261bb0de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = firebird-nspire
pkgdesc = Community emulator of TI-Nspire calculators.
- pkgver = 0.30
+ pkgver = 1.2
pkgrel = 1
- url = http://github.com/nspire-emus/firebird
+ url = https://github.com/nspire-emus/firebird
arch = i686
arch = x86_64
+ license = GPL3
+ makedepends = qt5-declarative>=5.6
+ makedepends = git
conflicts = nspire_emu
- makedepends = qt5-declarative
- source = https://github.com/nspire-emus/firebird/archive/v0.30.tar.gz
- md5sums = b441ef38da179a7e48c407d47d5cf294
+ source = firebird-nspire::git+https://github.com/nspire-emus/firebird
+ md5sums = SKIP
pkgname = firebird-nspire
+
diff --git a/PKGBUILD b/PKGBUILD
index 4e2846c799c8..d07dd53b2cba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,29 @@
# Contributor: Antonio Vázquez Blanco <antoniovazquezblanco@gmail.com>
+# Contributor: Haruue Icymoon <haruue@caoyue.com.cn>
pkgname=firebird-nspire
-pkgver=0.30
+pkgver=1.2
pkgrel=1
pkgdesc='Community emulator of TI-Nspire calculators.'
arch=('i686' 'x86_64')
url='https://github.com/nspire-emus/firebird'
conflicts=('nspire_emu')
-license=()
+license=('GPL3')
depends=()
-makedepends=('qt5-declarative')
-source=("$pkgname-$pkgver.tar.gz"::'https://github.com/nspire-emus/firebird/archive/v'$pkgver'.tar.gz')
-md5sums=('b441ef38da179a7e48c407d47d5cf294')
+makedepends=('qt5-declarative>=5.6' 'git')
+source=("${pkgname}"::'git+https://github.com/nspire-emus/firebird')
+md5sums=('SKIP')
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ git checkout -b "v${pkgver}" "v${pkgver}"
+ git submodule init
+ git submodule update
+}
build() {
# Compile...
- cd "${srcdir}/firebird-${pkgver}"
+ cd "${srcdir}/${pkgname}"
mkdir -p build
cd build
qmake ..
@@ -24,6 +32,7 @@ build() {
package() {
# Install...
- cd "${srcdir}/firebird-${pkgver}/build"
+ cd "${srcdir}/${pkgname}/build"
INSTALL_ROOT="${pkgdir}" make install
}
+