summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Bukowski2015-09-30 15:56:31 +0200
committerBenjamin Bukowski2015-09-30 15:56:31 +0200
commitcf6e658238f3b5738372e3f58767facf49cf63dc (patch)
treee8f7ef39d8a911dbf75f7d727f52b721fcf9050c
parent7a148514af3ed5dc5f7a496d8def6d2b2eb3d722 (diff)
downloadaur-cf6e658238f3b5738372e3f58767facf49cf63dc.tar.gz
Now compiling sources, and stop using upstream binaries.
Upstream firebird binaries has been compiled against ncurses version 5. Unfortunately ncurses has been updated to version 6, and firebird stopped working.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD59
-rwxr-xr-xfirebird-sysv.rc104
3 files changed, 40 insertions, 137 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55f27da268c9..5f011ab34de3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,23 @@
pkgbase = firebird-superserver
pkgdesc = A open source SQL relational database management system (RDMS)
pkgver = 2.5.4.26856_0
- pkgrel = 1
+ pkgrel = 2
url = http://www.firebirdsql.org/
install = firebird-superserver.install
arch = i686
arch = x86_64
- license = IPL IDPL
+ license = custom:IPL
+ license = custom:IDPL
+ depends = icu
+ depends = libedit
provides = libfbclient=2.5.4.26856
conflicts = firebird-classicserver
conflicts = libfbclient
- source = http://downloads.sourceforge.net/firebird/FirebirdSS-2.5.4.26856-0.i686.tar.gz
- source = firebird-sysv.rc
+ options = !makeflags
+ source = http://downloads.sourceforge.net/firebird/Firebird-2.5.4.26856-0.tar.bz2
source = firebird-tmpfiles.conf
source = firebird-systemd.service
- md5sums = 553d2027de702dc06ff077d7a0f4de83
- md5sums = 19e24e34c773826860958d4938396b05
+ md5sums = 7a17ec9889424b98baa29e001a054434
md5sums = 98eff99fd8d195a45c251610d67bd473
md5sums = ee9068e9bfdfa01e9dc79c72d1bfcdd8
diff --git a/PKGBUILD b/PKGBUILD
index 48c089cd308a..3d02971dbaef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,47 +3,50 @@ pkgname=firebird-superserver
_pkgver=2.5.4.26856
_buildver=0
pkgver=${_pkgver}_${_buildver}
-pkgrel=1
+pkgrel=2
pkgdesc="A open source SQL relational database management system (RDMS)"
arch=('i686' 'x86_64')
url="http://www.firebirdsql.org/"
-license=('IPL IDPL')
+license=('custom:IPL' 'custom:IDPL')
provides=("libfbclient=${_pkgver}")
-depends=()
+depends=('icu' 'libedit')
conflicts=('firebird-classicserver' 'libfbclient')
+options=('!makeflags')
install=firebird-superserver.install
-_arch=i686
-[[ "$CARCH" == x86_64 ]] && _arch=amd64
-
-_filename="FirebirdSS-${_pkgver}-${_buildver}.${_arch}"
-source=("http://downloads.sourceforge.net/firebird/${_filename}.tar.gz"
- 'firebird-sysv.rc'
+source=("http://downloads.sourceforge.net/firebird/Firebird-$_pkgver-$_buildver.tar.bz2"
'firebird-tmpfiles.conf'
'firebird-systemd.service')
-md5sums=('553d2027de702dc06ff077d7a0f4de83'
- '19e24e34c773826860958d4938396b05'
+md5sums=('7a17ec9889424b98baa29e001a054434'
'98eff99fd8d195a45c251610d67bd473'
'ee9068e9bfdfa01e9dc79c72d1bfcdd8')
-[[ "$CARCH" == x86_64 ]] && md5sums[0]='6b7a764b97f8ac810b1659c03e31d895'
+build() {
+ cd $srcdir/Firebird-$_pkgver-$_buildver
+
+ ./configure --prefix=/opt/firebird --libdir=/usr/lib --includedir=/usr/include \
+ --enable-superserver --with-system-icu --with-system-editline
+
+ make
+}
package() {
- cd "$srcdir/${_filename}"
-
- msg "Extracting firebird"
- tar -xzof buildroot.tar.gz -C $pkgdir
-
- [[ "$CARCH" == x86_64 ]] && mv $pkgdir/usr/lib64/ $pkgdir/usr/lib/
-
- install -Dm755 $srcdir/firebird-sysv.rc $pkgdir/etc/rc.d/firebird
+ cd $srcdir/Firebird-$_pkgver-$_buildver/gen
+
+ ./install/makeInstallImage.sh
+
+ cd $srcdir/Firebird-$_pkgver-$_buildver
+
+ cp -av gen/buildroot/* $pkgdir/
+
install -Dm644 $srcdir/firebird-systemd.service $pkgdir/usr/lib/systemd/system/firebird.service
install -Dm644 $srcdir/firebird-tmpfiles.conf $pkgdir/usr/lib/tmpfiles.d/firebird.conf
-
+ install -Dm644 $pkgdir/opt/firebird/IPLicense.txt $pkgdir/usr/share/licenses/IPLicense.txt
+ install -Dm644 $pkgdir/opt/firebird/IDPLicense.txt $pkgdir/usr/share/licenses/IDPLicense.txt
touch $pkgdir/opt/firebird/{fb_guard,firebird.log}
+
+ rm $pkgdir/opt/firebird/I{,D}PLicense.txt
- chmod u=rw,go= $pkgdir/opt/firebird/{fb_guard,firebird.log,security2.fdb,examples/empbuild/*.fdb}
-
cat << EOT > $pkgdir/opt/firebird/SYSDBA.password
# This is the default password
# You should change this password at the earliest oportunity
@@ -53,8 +56,6 @@ ISC_USER=SYSDBA
ISC_PASSWD=masterkey
EOT
- chmod u=r,go= $pkgdir/opt/firebird/SYSDBA.password
-
if [ -x $pkgdir/opt/firebird/bin/fbmgr.bin ]; then
cat > $pkgdir/opt/firebird/bin/fbmgr << EOT
#!/bin/sh
@@ -62,9 +63,13 @@ FIREBIRD=/opt/firebird
export FIREBIRD
exec /opt/firebird/bin/fbmgr.bin \$@
EOT
-fi
-chmod ugo+x $pkgdir/opt/firebird/bin/fbmgr
+ fi
+ chmod u=rw,go= $pkgdir/opt/firebird/{fb_guard,firebird.log,security2.fdb}
+ chmod -R ugo-w $pkgdir/opt/firebird/examples
+ chmod u=r,go= $pkgdir/opt/firebird/SYSDBA.password
+ chmod ugo+x $pkgdir/opt/firebird/bin/fbmgr
}
+
# vim:set ts=2 sw=2 et:
diff --git a/firebird-sysv.rc b/firebird-sysv.rc
deleted file mode 100755
index b9c3e95f91af..000000000000
--- a/firebird-sysv.rc
+++ /dev/null
@@ -1,104 +0,0 @@
-#!/bin/bash
-
-# description: Start/Stop firebird database server
-
-# To run more instances of firebird:
-# Copy /opt/firebird somewhere
-# Copy this script under a new name
-# Change INSTANCE and FIREBIRD below (all instance names should be unique)
-# Edit the copied firebird.conf to change at least RemoteServicePort
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-INSTANCE=default
-FIREBIRD=/opt/firebird
-DAEMON_NAME=`basename $0`
-
-# No changes needed below for multiple instances
-FBRunUser=firebird
-
-makeFbDir() {
- mDir=${1}
- mode=${2}
- if [ ! -d $mDir ]; then
- rm -rf $mDir
- mkdir $mDir
- if [ "$mode" ]; then
- chmod $mode $mDir
- fi
- fi
- chown $FBRunUser:$FBRunUser $mDir
-}
-runDir=/var/run/firebird
-makeFbDir $runDir
-lockDir=/tmp/firebird
-makeFbDir $lockDir 0770
-
-pidfile="$runDir/$INSTANCE.pid"
-FULLNAME="Firebird server [$INSTANCE]"
-LD_LIBRARY_PATH=$FIREBIRD/lib
-
-export FIREBIRD LD_LIBRARY_PATH
-
-GUARDIAN=$FIREBIRD/bin/fbguard
-if [ ! -x $GUARDIAN ]; then
- GUARDIAN=/opt/firebird/bin/fbguard
-fi
-
-# See how we were called.
-case "$1" in
- start)
- stat_busy "Starting $FULLNAME"
- echo "$GUARDIAN -pidfile $pidfile -daemon -forever" | su -s /bin/sh $FBRunUser
- #su $FBRunUser "$GUARDIAN -pidfile $pidfile -daemon -forever"
- RETVAL=$?
- if [ $RETVAL -gt 0 ]; then
- stat_fail
- else
- add_daemon $DAEMON_NAME
- stat_done
- fi
- ;;
- stop)
- stat_busy "Stopping $FULLNAME"
- RETVAL=1
- if [ -f $pidfile ]; then
- kill `cat $pidfile`
- RETVAL=$?
- fi
- if [ $RETVAL -gt 0 ]; then
- stat_fail
- else
- rm_daemon $DAEMON_NAME
- stat_done
- fi
- ;;
- status)
- if [ -f $pidfile ]
- then
- pid=`cat $pidfile`
- ps -p $pid >/dev/null 2>&1
- RETVAL=$?
- else
- RETVAL=1
- fi
- if [ $RETVAL -eq 0 ]
- then
- echo "$FULLNAME is running, pid $pid"
- else
- echo "$FULLNAME is stopped."
- fi
- ;;
- restart|reload)
- $0 stop
- sleep 1
- $0 start
- ;;
- *)
- echo "Usage: firebird {start|stop|status|restart|reload}"
- exit 1
-esac
-
-exit 0
-