summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorphre4k2016-03-26 01:10:51 +0100
committerphre4k2016-03-26 01:38:16 +0100
commitfdc434df6ad10919104b0ee5a7b132f5dc4026a8 (patch)
tree57b34de3b96b9f03cb946b0c3a501c4350da1380
downloadaur-fdc434df6ad10919104b0ee5a7b132f5dc4026a8.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore15
-rw-r--r--PKGBUILD24
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a647f39fab8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = firectl
+ pkgdesc = Modifies .desktop files for firejail.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/rahiel/firectl
+ arch = any
+ license = GPL2
+ makedepends = python3
+ depends = python
+ depends = python-click
+ source = https://pypi.python.org/packages/source/f/firectl/firectl-1.0.tar.gz
+ md5sums = 2bbf0b54d4074ac8cd5aa4bb1981c892
+
+pkgname = firectl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7f0aeb48fc95
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,15 @@
+# ignore everything
+*
+!.gitignore
+
+# except PKGBUILD needed files
+!PKGBUILD
+!.SRCINFO
+!*.install
+!ChangeLog
+
+# common wing-man files
+!*.diff
+!*.patch
+
+# add files that don't have an online source
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61d2fe5253a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: BlueSpirit < me AT phre4k DOT at >
+#Automatically generated by pip2arch on 2016-03-26
+
+pkgname=firectl
+pkgver=1.0
+pkgrel=1
+pkgdesc="Modifies .desktop files for firejail."
+url="https://github.com/rahiel/firectl"
+depends=('python' 'python-click' )
+makedepends=('python3' )
+license=('GPL2')
+arch=('any')
+source=('https://pypi.python.org/packages/source/f/firectl/firectl-1.0.tar.gz')
+md5sums=('2bbf0b54d4074ac8cd5aa4bb1981c892')
+
+build() {
+ cd $srcdir/firectl-1.0
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/firectl-1.0
+ python setup.py install --root="$pkgdir" --optimize=1
+}