summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordr460nf1r32022-02-05 16:58:59 +0100
committerdr460nf1r32022-02-05 16:58:59 +0100
commitd031b85c6b1ec3c50020aed2a986b9fdfe59183e (patch)
tree1ff2cf68dc90e044b12bc9da2723d530401a54a0
parent341561d3e5921724770e950397a332b95da48798 (diff)
downloadaur-d031b85c6b1ec3c50020aed2a986b9fdfe59183e.tar.gz
Update, add latest Librewolf changes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD22
2 files changed, 22 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0144562320cb..93c33a46d971 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = firedragon
pkgdesc = Librewolf fork build using custom branding, settings & KDE patches by OpenSUSE
pkgver = 96.0.3
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/dr460nf1r3/settings/
install = firedragon.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index a23aaf5216ec..cb4b95623bab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=firedragon
_pkgname=FireDragon
pkgver=96.0.3
-pkgrel=1
+pkgrel=2
pkgdesc="Librewolf fork build using custom branding, settings & KDE patches by OpenSUSE"
arch=(x86_64 x86_64_v3)
backup=('usr/lib/firedragon/firedragon.cfg'
@@ -96,15 +96,32 @@ prepare() {
echo "---- Librewolf patches"
patch -Np1 -i ${_patches_dir}/librewolf/remove_addons.patch
+ # somewhat experimental patch to fix bus/dbus/remoting names to io.gitlab.librewolf
+ # should not break things, buuuuuuuuuut we'll see.
+ patch -Np1 -i ${_patches_dir}/dbus_name.patch
+
+ # allow uBlockOrigin to run in private mode by default, without user intervention.
+ patch -Np1 -i ${_patches_dir}/allow-ubo-private-mode.patch
+
+ # add custom uBO assets (on first launch only)
+ patch -Np1 -i ${_patches_dir}/custom-ubo-assets-bootstrap-location.patch
+
# Debian patch to enable global menubar
patch -Np1 -i ${_patches_dir}/librewolf/unity-menubar.patch
+ # custom patch that does not conflict with the unity patch
+ patch -Np1 -i ${_patches_dir}/mozilla-kde_after_unity.patch
+
# Remove Mozilla VPN ads
patch -Np1 -i ${_patches_dir}/librewolf/mozilla-vpn-ad.patch
# Allow SearchEngines option in non-ESR builds
patch -Np1 -i ${_patches_dir}/sed-patches/allow-searchengines-non-esr.patch
+ # remove search extensions (experimental)
+ # patch -Np1 -i ${_patches_dir}/search-config.patch
+ cp "${srcdir}/common/source_files/search-config.json" services/settings/dumps/main/search-config.json
+
# Stop some undesired requests (https://gitlab.com/librewolf-community/browser/common/-/issues/10)
patch -Np1 -i ${_patches_dir}/sed-patches/stop-undesired-requests.patch
@@ -132,6 +149,9 @@ prepare() {
patch -Np1 -i ${_patches_dir}/librewolf-ui/pref_pane.patch
patch -Np1 -i ${_patches_dir}/misc/add_firedragon_svg.patch
+ # fix telemetry removal, see https://gitlab.com/librewolf-community/browser/linux/-/merge_requests/17, for example
+ patch -Np1 -i ${_patches_dir}/disable-data-reporting-at-compile-time.patch
+
echo "---- Fixing build issues"
# Needed patch to have build working
patch -Np1 -i ${_patches_dir}/misc/fix-wayland.patch