summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordr460nf1r32022-06-11 11:57:36 +0200
committerdr460nf1r32022-06-11 11:57:36 +0200
commitf861e8d2437bf024022c4e5cd1319949525209ee (patch)
treec4ad38992f7a1fded346ddc820f33f6f15c08d74
parentb0f3e16228f9f42b6ae44a33ff0fa05a556d5745 (diff)
downloadaur-f861e8d2437bf024022c4e5cd1319949525209ee.tar.gz
Update
-rw-r--r--PKGBUILD69
1 files changed, 31 insertions, 38 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8e5960440a5..b285b39e6635 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=firedragon
_pkgname=FireDragon
-pkgver=101.0
+pkgver=101.0.1
pkgrel=1
pkgdesc="Librewolf fork build using custom branding, settings & KDE patches by OpenSUSE"
arch=(x86_64 x86_64_v3 aarch64)
@@ -39,7 +39,7 @@ source=(https://archive.mozilla.org/pub/firefox/releases/"$pkgver"/source/firefo
"librewolf-settings::git+https://gitlab.com/librewolf-community/settings.git"
"cachyos-source::git+https://github.com/CachyOS/CachyOS-Browser-Common.git")
# source_aarch64=()
-sha256sums=('55ab5b517d58bbcbc837640263a8371cf1fba3d9f508e54537c4d2cbbfb86095'
+sha256sums=('b4c76e8bdf81f473f3e56b2f69dbe5119bba5cab38e36ab0f3f38cf0cdc4a9c2'
'SKIP'
'158152bdb9ef6a83bad62ae03a3d9bc8ae693b34926e53cc8c4de07df20ab22d'
'SKIP'
@@ -169,108 +169,101 @@ export LDFLAGS+=" -Wl,--no-keep-memory"
END
fi
- # upstream patches from gentoo
-
- # pgo improvements
+ # Upstream patches from gentoo
+ # PGO improvements
patch -Np1 -i "${_patches_dir}"/gentoo/0018-bmo-1516081-Disable-watchdog-during-PGO-builds.patch
# LibreWolf
-
# Remove some pre-installed addons that might be questionable
patch -Np1 -i "${_librewolf_patches_dir}"/remove_addons.patch
# Debian patch to enable global menubar
- # disabled for the default build, as it seems to cause issues in some configurations
- # 2022-01-21: re-enabled because it seems to not mess things up anymore nowadays?
- # patch -Np1 -i "${_librewolf_patches_dir}"/unity-menubar.patch
+ patch -Np1 -i "${_librewolf_patches_dir}"/unity-menubar.patch
# KDE menu
- patch -Np1 -i "${_cachyos_patches_dir}"/kde/0001-kde-unity.patch
- patch -Np1 -i "${_cachyos_patches_dir}"/kde/mozilla-nongnome-proxies.patch
+ patch -Np1 -i "${_librewolf_patches_dir}"/mozilla-kde_after_unity.patch
+ patch -Np1 -i "${_cachyos_patches_dir}"/kde/mozilla-nongnome-proxies.patch
# Disabling Pocket
patch -Np1 -i "${_librewolf_patches_dir}"/sed-patches/disable-pocket.patch
- # Remove Internal Plugin Certificates
- # patch -Np1 -i "${_librewolf_patches_dir}"/sed-patches/remove-internal-plugin-certs.patch
- # => breaks profiled builds since 90.0, it seems
-
- # allow SearchEngines option in non-ESR builds
+ # Allow SearchEngines option in non-ESR builds
patch -Np1 -i "${_librewolf_patches_dir}"/sed-patches/allow-searchengines-non-esr.patch
- # remove search extensions (experimental)
- # patch -Np1 -i "${_librewolf_patches_dir}"/search-config.patch
+ # Remove search extensions (experimental)
cp "${srcdir}/librewolf-source/assets/search-config.json" services/settings/dumps/main/search-config.json
- # stop some undesired requests (https://gitlab.com/librewolf-community/browser/common/-/issues/10)
+ # Stop some undesired requests (https://gitlab.com/librewolf-community/browser/common/-/issues/10)
patch -Np1 -i "${_librewolf_patches_dir}"/sed-patches/stop-undesired-requests.patch
# Assorted patches
patch -Np1 -i "${_librewolf_patches_dir}"/urlbarprovider-interventions.patch
- # change some hardcoded directory strings that could lead to unnecessarily
- # created directories
+ # Change some hardcoded directory strings that could lead to unnecessarily
+ # Created directories
patch -Np1 -i "${_librewolf_patches_dir}"/mozilla_dirs.patch
# somewhat experimental patch to fix bus/dbus/remoting names to io.gitlab.librewolf
# should not break things, buuuuuuuuuut we'll see.
patch -Np1 -i "${_librewolf_patches_dir}"/dbus_name.patch
- # allow uBlockOrigin to run in private mode by default, without user intervention.
+ # Allow uBlockOrigin to run in private mode by default, without user intervention.
patch -Np1 -i "${_librewolf_patches_dir}"/allow-ubo-private-mode.patch
- # add custom uBO assets (on first launch only)
+ # Add custom uBO assets (on first launch only)
patch -Np1 -i "${_librewolf_patches_dir}"/custom-ubo-assets-bootstrap-location.patch
- # ui patches
-
- # remove references to firefox from the settings UI, change text in some of the links,
+ # UI patches
+ # Remove references to firefox from the settings UI, change text in some of the links,
# explain that we force en-US and suggest enabling history near the session restore checkbox.
patch -Np1 -i "${_librewolf_patches_dir}"/ui-patches/pref-naming.patch
- #
+ # Remap help links
patch -Np1 -i "${_librewolf_patches_dir}"/ui-patches/remap-links.patch
- #
+ # Don't nag to set default browser
patch -Np1 -i "${_librewolf_patches_dir}"/ui-patches/hide-default-browser.patch
# Add LibreWolf logo to Debugging Page
patch -Np1 -i "${_librewolf_patches_dir}"/ui-patches/lw-logo-devtools.patch
- #
+ # Update privacy preferences
patch -Np1 -i "${_librewolf_patches_dir}"/ui-patches/privacy-preferences.patch
- # remove firefox references in the urlbar, when suggesting opened tabs.
+ # Remove firefox references in the urlbar, when suggesting opened tabs.
patch -Np1 -i "${_librewolf_patches_dir}"/ui-patches/remove-branding-urlbar.patch
- # remove cfr UI elements, as they are disabled and locked already.
+ # Remove cfr UI elements, as they are disabled and locked already.
patch -Np1 -i "${_librewolf_patches_dir}"/ui-patches/remove-cfrprefs.patch
- # do not display your browser is being managed by your organization in the settings.
+ # Do not display your browser is being managed by your organization in the settings.
patch -Np1 -i "${_librewolf_patches_dir}"/ui-patches/remove-organization-policy-banner.patch
- # hide "snippets" section from the home page settings, as it was already locked.
+ # Hide "snippets" section from the home page settings, as it was already locked.
patch -Np1 -i "${_librewolf_patches_dir}"/ui-patches/remove-snippets-from-home.patch
- # add warning that sanitizing exceptions are bypassed by the options in History > Clear History when LibreWolf closes > Settings
+ # Add warning that sanitizing exceptions are bypassed by the options in History > Clear History when LibreWolf closes > Settings
patch -Np1 -i "${_librewolf_patches_dir}"/ui-patches/sanitizing-description.patch
- # add patch to hide website appearance settings
+ # Add patch to hide website appearance settings
patch -Np1 -i "${_librewolf_patches_dir}"/ui-patches/website-appearance-ui-rfp.patch
- #
+ # Update handler links
patch -Np1 -i "${_librewolf_patches_dir}"/ui-patches/handlers.patch
- # fix telemetry removal, see https://gitlab.com/librewolf-community/browser/linux/-/merge_requests/17, for example
+ # Fix telemetry removal, see https://gitlab.com/librewolf-community/browser/linux/-/merge_requests/17, for example
patch -Np1 -i "${_librewolf_patches_dir}"/disable-data-reporting-at-compile-time.patch
- # allows hiding the password manager (from the lw pref pane) / via a pref
+ # Allows hiding the password manager (from the lw pref pane) / via a pref
patch -Np1 -i "${_librewolf_patches_dir}"/hide-passwordmgr.patch
# Pref pane - custom FireDragon svg
patch -Np1 -i "${_patches_dir}"/custom/librewolf-pref-pane.patch
patch -Np1 -i "${_patches_dir}"/custom/add_firedragon_svg.patch
+ # Needed build fix
+ patch -Np1 -i "${_patches_dir}"/gentoo/0032-bmo-1773259-cbindgen-root_clip_chain-fix.patch
+
rm -f "${srcdir}"/common/source_files/mozconfig
cp -r "${srcdir}"/common/source_files/* ./
}