summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordr460nf1r32022-05-15 10:39:50 +0200
committerdr460nf1r32022-05-15 10:39:50 +0200
commitfbdecf0f0d1c1d1098b9998c8d954f026a459e2b (patch)
tree120873781d451536873737a601398f6c4c7d1807
parent1585f97d8917a7b9b3e4a5258edb3af80881fffb (diff)
downloadaur-fbdecf0f0d1c1d1098b9998c8d954f026a459e2b.tar.gz
And another one
-rw-r--r--PKGBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a94e31db7aa..9b952b61aa13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -243,7 +243,7 @@ build() {
export MOZ_NOSPAM=1
export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
- export BUILD_PYTHON_NATIVE_PACKAGE_SOURCE=system
+ export MACH_BUILD_PYTHON_NATIVE_PACKAGE_SOURCE=system
# LTO needs more open files
ulimit -n 4096
@@ -251,14 +251,12 @@ build() {
# Do 3-tier PGO
echo "Building instrumented browser..."
- cat >.mozconfig ../mozconfig - <<END
-ac_add_options --enable-profile-generate=cross
-END
-
./mach build
echo "Profiling instrumented browser..."
+
./mach package
+
LLVM_PROFDATA=llvm-profdata \
JARLOG_FILE="$PWD/jarlog" \
xvfb-run -s "-screen 0 1920x1080x24 -nolisten local" \
@@ -280,8 +278,6 @@ ac_add_options --enable-lto=cross
ac_add_options --enable-profile-use=cross
ac_add_options --with-pgo-profile-path=${PWD@Q}/merged.profdata
ac_add_options --with-pgo-jarlog=${PWD@Q}/jarlog
-ac_add_options --enable-linker=lld
-ac_add_options --disable-bootstrap
END
./mach build