summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordr460nf1r32021-12-12 19:55:40 +0100
committerdr460nf1r32021-12-12 19:55:40 +0100
commit2499a0a6518a3a5d7b1b6e17d9cd3ce808a12877 (patch)
treee88157980f3a1de6eac849ff1dd175098b23743c
parent5e76f576dc6b9028a5604d010605f02126cfc945 (diff)
downloadaur-2499a0a6518a3a5d7b1b6e17d9cd3ce808a12877.tar.gz
Update
-rw-r--r--PKGBUILD47
1 files changed, 24 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e450e613c90d..b61b7633120a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ provides=(firedragon)
url="https://gitlab.com/dr460nf1r3/settings/"
depends=(gtk3 libxt mime-types dbus-glib ffmpeg nss-hg nspr-hg ttf-font libpulse
libwebp libvpx libjpeg zlib icu libevent pipewire aom harfbuzz
- graphite dav1d)
+ graphite dav1d xorg-server-xwayland)
makedepends=(unzip zip diffutils yasm mesa imake inetutils xorg-server-xvfb nasm
rust ccache autoconf2.13 clang llvm jack gtk2 nodejs cbindgen wasi-sdk-git
python-setuptools python-psutil python-zstandard git binutils lld dump_syms)
@@ -153,6 +153,7 @@ ac_add_options --with-system-libevent
ac_add_options --with-system-libvpx
ac_add_options --with-system-nspr
ac_add_options --with-system-nss
+ac_add_options --with-system-webp
ac_add_options --with-system-zlib
# Features
@@ -240,53 +241,53 @@ build() {
# CXXFLAGS="${CXXFLAGS/-fno-plt/}"
# Do 3-tier PGO
- echo "Building instrumented browser..."
+# echo "Building instrumented browser..."
if [[ $CARCH == 'aarch64' ]]; then
cat >.mozconfig ../mozconfig - <<END
-ac_add_options --enable-profile-generate
+#ac_add_options --enable-profile-generate
END
else
cat >.mozconfig ../mozconfig - <<END
-ac_add_options --enable-profile-generate=cross
+#ac_add_options --enable-profile-generate=cross
END
fi
- ./mach build
+# ./mach build
- echo "Profiling instrumented browser..."
- ./mach package
- LLVM_PROFDATA=llvm-profdata \
- JARLOG_FILE="$PWD/jarlog" \
- xvfb-run -s "-screen 0 1920x1080x24 -nolisten local" \
- ./mach python build/pgo/profileserver.py
+# echo "Profiling instrumented browser..."
+# ./mach package
+# LLVM_PROFDATA=llvm-profdata \
+# JARLOG_FILE="$PWD/jarlog" \
+# xvfb-run -s "-screen 0 1920x1080x24 -nolisten local" \
+# ./mach python build/pgo/profileserver.py
if [[ ! -s merged.profdata ]]; then
- echo "No profile data produced."
+# echo "No profile data produced."
return 1
fi
if [[ ! -s jarlog ]]; then
- echo "No jar log produced."
- return 1
+# echo "No jar log produced."
+# return 1
fi
- echo "Removing instrumented browser..."
- ./mach clobber
+# echo "Removing instrumented browser..."
+# ./mach clobber
- echo "Building optimized browser..."
+# echo "Building optimized browser..."
if [[ $CARCH == 'aarch64' ]]; then
cat >.mozconfig ../mozconfig - <<END
ac_add_options --enable-lto
-ac_add_options --enable-profile-use
-ac_add_options --with-pgo-profile-path=${PWD@Q}/merged.profdata
-ac_add_options --with-pgo-jarlog=${PWD@Q}/jarlog
+#ac_add_options --enable-profile-use
+#ac_add_options --with-pgo-profile-path=${PWD@Q}/merged.profdata
+#ac_add_options --with-pgo-jarlog=${PWD@Q}/jarlog
ac_add_options --enable-linker=lld
END
@@ -294,9 +295,9 @@ else
cat >.mozconfig ../mozconfig - <<END
ac_add_options --enable-lto=cross
-ac_add_options --enable-profile-use=cross
-ac_add_options --with-pgo-profile-path=${PWD@Q}/merged.profdata
-ac_add_options --with-pgo-jarlog=${PWD@Q}/jarlog
+#ac_add_options --enable-profile-use=cross
+#ac_add_options --with-pgo-profile-path=${PWD@Q}/merged.profdata
+#ac_add_options --with-pgo-jarlog=${PWD@Q}/jarlog
ac_add_options --enable-linker=lld
ac_add_options --disable-elf-hack
END