summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorstefanwimmer1282023-11-01 10:34:34 +0100
committerstefanwimmer1282023-11-22 12:43:39 +0100
commit4236ef60977a279ad9e95d0e4b27f2e690b19dbe (patch)
tree9fe04d35b145fd2e2620e145aa58e5317eb55c0e
parent123505d997071ec559bc49254f58c55784ef7368 (diff)
downloadaur-4236ef60977a279ad9e95d0e4b27f2e690b19dbe.tar.gz
Move to new pref-pane implementation
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf49ed4a1a65..91841a49e64b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -73,7 +73,7 @@ pkgbase = firedragon-unsigned-extensions
source = https://archive.mozilla.org/pub/firefox/releases/120.0/source/firefox-120.0.source.tar.xz
source = https://archive.mozilla.org/pub/firefox/releases/120.0/source/firefox-120.0.source.tar.xz.asc
source = firedragon.desktop
- source = git+https://gitlab.com/dr460nf1r3/common.git
+ source = common::git+https://gitlab.com/stefanwimmer128/firedragon-common.git#branch=pref-pane
source = git+https://gitlab.com/dr460nf1r3/settings.git
source = librewolf-source::git+https://codeberg.org/librewolf/source.git#tag=120.0-1
source = librewolf-settings::git+https://codeberg.org/librewolf/settings.git
diff --git a/PKGBUILD b/PKGBUILD
index 6eff77f4cf18..cbbf2a672c85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -42,7 +42,7 @@ options=(!emptydirs !makeflags !strip !lto !debug)
install=$__pkgname.install
source=(https://archive.mozilla.org/pub/firefox/releases/"$pkgver"/source/firefox-"$pkgver".source.tar.xz{,.asc}
"$__pkgname.desktop"
- "git+https://gitlab.com/dr460nf1r3/common.git"
+ "common::git+https://gitlab.com/stefanwimmer128/firedragon-common.git#branch=pref-pane"
"git+https://gitlab.com/dr460nf1r3/settings.git"
"librewolf-source::git+https://codeberg.org/librewolf/source.git#tag=120.0-1"
"librewolf-settings::git+https://codeberg.org/librewolf/settings.git"
@@ -224,8 +224,14 @@ END
patch -Np1 -i "${_librewolf_patches_dir}"/hide-passwordmgr.patch
# Pref pane - custom FireDragon svg
- patch -Np1 -i "${_patches_dir}"/custom/librewolf-pref-pane.patch
- patch -Np1 -i "${_patches_dir}"/custom/add_firedragon_svg.patch
+ patch -Np1 -i "${_patches_dir}"/custom/pref-pane/pref-pane-small.patch
+ cp "${_patches_dir}"/custom/pref-pane/category-librewolf.svg browser/themes/shared/preferences/category-librewolf.svg
+ cp "${_patches_dir}"/custom/pref-pane/librewolf.css browser/themes/shared/preferences/librewolf.css
+ cp "${_patches_dir}"/custom/pref-pane/librewolf.inc.xhtml browser/components/preferences/librewolf.inc.xhtml
+ cp "${_patches_dir}"/custom/pref-pane/librewolf.js browser/components/preferences/librewolf.js
+ cat < "${_patches_dir}"/custom/pref-pane/preferences.ftl >> browser/locales/en-US/browser/preferences/preferences.ftl
+
+
# Update privacy preferences
patch -Np1 -i "${_patches_dir}"/custom/privacy-preferences.patch